Bug 193734 - Removed PLIST_REINPLACE macro breaks net/samba4* and emulators/i386-wine*
Summary: Removed PLIST_REINPLACE macro breaks net/samba4* and emulators/i386-wine*
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Some People
Assignee: Timur I. Bakeyev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-18 07:21 UTC by SHIMAYOSHI, Takao
Modified: 2014-12-15 00:55 UTC (History)
4 users (show)

See Also:


Attachments
Workarround PLIST_REINPLACE plist, hence operational breakage (415 bytes, patch)
2014-10-13 17:31 UTC, Harald Schmalzbauer
no flags Details | Diff
fix PLIST_SUB for SAMBA4_MODULES and move "vfs_notify_fam" handling (1.12 KB, patch)
2014-11-03 19:28 UTC, Harald Schmalzbauer
no flags Details | Diff
fix PLIST_SUB for SAMBA4_MODULES and move "vfs_notify_fam" handling (1.12 KB, patch)
2014-11-03 19:42 UTC, Harald Schmalzbauer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description SHIMAYOSHI, Takao 2014-09-18 07:21:58 UTC
PLIST_REINPLACE macro, which was removed from bsd.port.mk at Revision 367153, is still utilised in the following ports; emulators/i386-wine-devel, emulators/i386-wine, net/samba4, net/samba41.
This has been disabling to make these ports.
Comment 1 Marcus von Appen freebsd_committer freebsd_triage 2014-09-19 06:28:43 UTC
Added the maintainers of the ports to the CC list.
Comment 2 commit-hook freebsd_committer 2014-09-22 18:26:08 UTC
A commit references this bug:

Author: dbn
Date: Mon Sep 22 18:25:56 UTC 2014
New revision: 368984
URL: http://svnweb.freebsd.org/changeset/ports/368984

Log:
  Unbreak emulators/i386-wine(-devel) builds.

  With the removal of REINPLACE_PLIST in r367153 building wine on FreeBSD/i386
  broke.  This was not detected in an exp-run as i386-wine is marked IGNORE
  unless WINE_CROSS_BUILD is defined (to protect the build infrastructure and
  avoid confusion).

  PR:	193734

Changes:
  head/emulators/i386-wine/Makefile.i386
  head/emulators/i386-wine-devel/Makefile.i386
Comment 3 David Naylor freebsd_committer 2014-09-22 18:30:57 UTC
My ports have been fixed.  Over to timur for fixing samba.  

Thank you for your report :-).  Please ping the bug if there hasn't been any movement in 2 weeks.
Comment 4 Timur I. Bakeyev freebsd_committer 2014-10-05 22:07:01 UTC
I'm trying to come with the easy fix for the problem...
Comment 5 Harald Schmalzbauer 2014-10-13 17:31:50 UTC
Created attachment 148268 [details]
Workarround PLIST_REINPLACE plist, hence operational breakage

Updating net/samba41 on a production system brings service down :-(
Culprit is:
Error loading module '/usr/local/lib/shared-modules/vfs/notify_fam.so': Cannot open "/usr/local/lib/shared-modules/vfs/notify_fam.so"
pkg-plist is silently broken for four weeks for all SAMBA4_MODULES (containing WANT_EXP_MODULES).
The problem is that e.g. vfs_notify_fam is enabled by default, so installing a samba41 package, built after PLIST_REINPLACE macro was removed, breaks SMB/CIFS service.
Please find attached a quick workarround. At least, it fixes samba-update-breakage! So either the port must be marked broken or any fix should be comitted asap.
Comment 6 Timur I. Bakeyev freebsd_committer 2014-10-20 16:10:00 UTC
Done for net/samba41/ Samba4 to follow.
Comment 7 Harald Schmalzbauer 2014-11-03 19:28:12 UTC
Created attachment 148996 [details]
fix PLIST_SUB for SAMBA4_MODULES and move "vfs_notify_fam" handling
Comment 8 Harald Schmalzbauer 2014-11-03 19:29:22 UTC
(In reply to Timur I. Bakeyev from comment #6)
> Done for net/samba41/ Samba4 to follow.

Unfortunately the fix to replace PLIST_REINPLACE in https://svnweb.freebsd.org/changeset/ports/371268 doesn't work because "if !empty(${SAMBA4_MODULES}) &&…" should read "if !empty(SAMBA4_MODULES) &&…".

But I attached a different patch, since to me it seems the whole EXP_MODULES is broken bebause those are not defined at all in pkg-plist (at least the particular I checked) and needs to get some attention (which I don't have time for, sorry).
For now, to make the port working, the patch corrects the syntactical error and moves "vfs_notify_fam" out of the EXP_MODULE/SAMBA4_MODULE handling (although the above mentioned correction fixes it alone!).
Comment 9 Harald Schmalzbauer 2014-11-03 19:42:16 UTC
Created attachment 148997 [details]
fix PLIST_SUB for SAMBA4_MODULES and move "vfs_notify_fam" handling

Sorry, this time the correct version of the patch, described in my last comment
Comment 10 Timur I. Bakeyev freebsd_committer 2014-11-03 20:29:11 UTC
Thanks for the patch, pity you spotted it a bit late to address #194548.
Comment 11 Timur I. Bakeyev freebsd_committer 2014-12-15 00:55:58 UTC
Ok, finally committed fix for samba4 also. We can close this PR.