Bug 194063 - [uefi] installer fails to boot / kernel panic on HP Probook 430 G1
Summary: [uefi] installer fails to boot / kernel panic on HP Probook 430 G1
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.1-STABLE
Hardware: amd64 Any
: --- Affects Some People
Assignee: Marcel Moolenaar
URL:
Keywords: i915, uefi, vt
Depends on:
Blocks:
 
Reported: 2014-10-01 09:44 UTC by Oliver Pinter
Modified: 2015-08-13 19:30 UTC (History)
7 users (show)

See Also:


Attachments
picture of the panic (551.35 KB, image/jpeg)
2014-10-01 09:44 UTC, Oliver Pinter
no flags Details
linux's dmesg (57.00 KB, text/plain)
2014-10-01 09:56 UTC, Oliver Pinter
no flags Details
linux's lspci (8.52 KB, text/plain)
2014-10-01 09:57 UTC, Oliver Pinter
no flags Details
load prompt in UEFI native mode (without CSM) (291.56 KB, image/jpeg)
2014-10-01 15:23 UTC, Oliver Pinter
no flags Details
load prompt in UEFI native mode (without CSM) (464.59 KB, image/jpeg)
2014-10-01 15:24 UTC, Oliver Pinter
no flags Details
hbsd-11 native mode w/o csm (254.20 KB, image/jpeg)
2014-10-03 11:11 UTC, Oliver Pinter
no flags Details
hbsd-11 hybrid mode w/ csm (336.29 KB, image/jpeg)
2014-10-03 11:12 UTC, Oliver Pinter
no flags Details
hbsd-11 hybrid mode w/ csm (336.29 KB, image/jpeg)
2014-10-03 11:13 UTC, Oliver Pinter
no flags Details
hbsd-11 hybrid mode w/ csm (336.34 KB, image/jpeg)
2014-10-03 11:13 UTC, Oliver Pinter
no flags Details
hbsd-11 hybrid mode w/ csm (334.13 KB, image/jpeg)
2014-10-03 11:26 UTC, Oliver Pinter
no flags Details
fbsd10rc1 uefi hybrid mode with csm (445.86 KB, image/jpeg)
2014-10-06 18:49 UTC, Oliver Pinter
no flags Details
fbsd10rc1 uefi native mode without csm (306.66 KB, image/jpeg)
2014-10-06 18:50 UTC, Oliver Pinter
no flags Details
mostly working loader from FreeBSD 9.3-RELEASE (224.00 KB, application/octet-stream)
2014-10-11 23:21 UTC, Oliver Pinter
no flags Details
broken loader from 11-CURRENT (260.00 KB, application/octet-stream)
2014-10-11 23:22 UTC, Oliver Pinter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Pinter freebsd_committer 2014-10-01 09:44:24 UTC
Created attachment 147876 [details]
picture of the panic

The system is a HP Probook 430 G1 with Intel Core i5-4200U CPU and with integrated GPU.

The kernel paniced with 10.1-BETA3 and current 11-SNAPSHOT too. See the attached picture.
Comment 1 Oliver Pinter freebsd_committer 2014-10-01 09:56:38 UTC
Created attachment 147878 [details]
linux's dmesg
Comment 2 Oliver Pinter freebsd_committer 2014-10-01 09:57:07 UTC
Created attachment 147879 [details]
linux's lspci
Comment 3 Oliver Pinter freebsd_committer 2014-10-01 10:40:33 UTC
addr2line "RIP":

sys/vm/vm_map.c:502

map->system_map does not exists

void
_vm_map_lock_read(vm_map_t map, const char *file, int line)
{
  if (map->system_map)
    mtx_lock_flags_(&map->system_mtx, 0, file, line);
  else
    sx_slock_(&map->lock, file, line);
}
Comment 4 Oliver Pinter freebsd_committer 2014-10-01 15:14:01 UTC
After BIOS update to latest BIOS, the problem _not_ changed.
Comment 5 Oliver Pinter freebsd_committer 2014-10-01 15:18:22 UTC
This is with UEFI Hybrid mode (with CSM).
Comment 6 Oliver Pinter freebsd_committer 2014-10-01 15:23:02 UTC
Created attachment 147887 [details]
load prompt in UEFI native mode (without CSM)
Comment 7 Ed Maste freebsd_committer 2014-10-01 15:23:17 UTC
Would you kindly addr2line the previous few addresses in the backtrace?
Comment 8 Oliver Pinter freebsd_committer 2014-10-01 15:24:03 UTC
Created attachment 147888 [details]
load prompt in UEFI native mode (without CSM)

I got this screen, when booting with UEFI native mode (without CSM). Possibly this is an kernel panic.
Comment 9 Ed Maste freebsd_committer 2014-10-01 15:26:54 UTC
This looks like it might just be incorrect framebuffer information.
You may be able to try blindly logging in, or blindly rebooting if you're in ddb.
Comment 10 Oliver Pinter freebsd_committer 2014-10-01 17:28:23 UTC
Seems like the system is in ddb or something similar, because when I pressed the power button, the system immediately go to S5 (shuting down).
Comment 11 Ed Maste freebsd_committer 2014-10-01 17:31:54 UTC
Does the screen change after kernel starts, or does it show the same static corruption the whole time?  (I.e., it's useful to know if it's booting up and then panics, or happens very early on.)

You can confirm it's in ddb by blindly typing 'reset' and hitting enter -- if it does reboot, then it was in ddb.
Comment 12 Oliver Pinter freebsd_committer 2014-10-02 05:42:28 UTC
To this point the screen changed. The blindly writing trick don't working, because to early to initialize the keyboard.

If I try boot -v in hybrid mode, I got a different trap: Privileged instructionn fault in cam_compat.c +60 line of 10.1-BETA3. But at this point it's again to early to get a working keyboard.

After that I tried to boot w/ and w/o EFI signing keys to boot, but none of them worked.

Is there any EFI facility to create EFI logs, which I can read via EFI BIOS menu?
Comment 13 Oliver Pinter freebsd_committer 2014-10-03 11:11:58 UTC
Created attachment 147929 [details]
hbsd-11 native mode w/o csm
Comment 14 Oliver Pinter freebsd_committer 2014-10-03 11:12:49 UTC
Created attachment 147930 [details]
hbsd-11 hybrid mode w/ csm
Comment 15 Oliver Pinter freebsd_committer 2014-10-03 11:13:06 UTC
Created attachment 147931 [details]
hbsd-11 hybrid mode w/ csm
Comment 16 Oliver Pinter freebsd_committer 2014-10-03 11:13:26 UTC
Created attachment 147932 [details]
hbsd-11 hybrid mode w/ csm
Comment 17 Oliver Pinter freebsd_committer 2014-10-03 11:19:02 UTC
http://www.crysys.hu/~op/freebsd/memstick-debug.img

Builded a new memstick installer, and enabled VERBOSE_SYSINIT and DEBUG options in kernel config, but these options don't have any effect.

With CURRENT, I got a running DDB. In native mode w/o CSM the kernel hanged up after printed out terminal settings. In native mode defaulted to 1366x768 resolution.

In hybrid mode, the system goes towards, but paniced due NULL pointer deref. The stack traces are in newly uploaded images. The R12 registers value is 0, and the system derefed this. In hybrid mode, the system defaulted to 1024x768 resolution.
Comment 18 Oliver Pinter freebsd_committer 2014-10-03 11:26:58 UTC
Created attachment 147933 [details]
hbsd-11 hybrid mode w/ csm
Comment 19 Oliver Pinter freebsd_committer 2014-10-06 18:49:54 UTC
Created attachment 148041 [details]
fbsd10rc1 uefi hybrid mode with csm
Comment 20 Oliver Pinter freebsd_committer 2014-10-06 18:50:33 UTC
Created attachment 148042 [details]
fbsd10rc1 uefi native mode without csm
Comment 21 Oliver Pinter freebsd_committer 2014-10-11 22:26:03 UTC
I can boot my 430, if I copied the 9.3 /boot/loader to installer (as troyax mentioned in #187488) but only if I hit ESC and after it ENTER in first stage loader.

Probably there are differences between gcc and clang generated /boot/loader. I'm now investigating in this way.
Comment 22 Oliver Pinter freebsd_committer 2014-10-11 23:21:26 UTC
Created attachment 148207 [details]
mostly working loader from FreeBSD 9.3-RELEASE

added mostly working loader in legacy mode from FreeBSD 9.3-RELEASE
Comment 23 Oliver Pinter freebsd_committer 2014-10-11 23:22:16 UTC
Created attachment 148208 [details]
broken loader from 11-CURRENT

broken loader in legacy mode from 11-CURRENT
Comment 24 Oliver Pinter freebsd_committer 2014-10-17 12:30:44 UTC
The UEFI mode remained broken, but in legacy mode I can install FreeBSD with the described hack.

In overall, in legacy mode the system will boot if copied the loader binary (compiled with gcc) from FreeBSD 9.3 release to memstick usb installer, and named loader.gcc, and manually change to load them at boot time.

After this, the installation completed as expected and the system able to boot up with the original 11-CURRENT's loader (which compiled with clang).
Comment 25 sajina_99 2014-11-16 22:05:50 UTC
I'm having the exact same problem with my HP ProBook 6475b (CPU: A6-4400M) with BIOS F.47 and the latest F.50 Rev.A. So it might be not a problem that is limited to the ProBook G430 G1 but a problem with the UEFI used by HP.
Comment 26 xmisterhu 2014-12-10 18:12:25 UTC
I had the same problem on my Pavilion x2.
The solution for me was to use "mode 3" before boot.
This works on 10.1, however it is not working on 11-CURRENT.
Comment 27 Oliver Pinter freebsd_committer 2014-12-11 00:00:28 UTC
Try this installer: http://www.crysys.hu/~op/freebsd/memstick-debug.img
Comment 28 xmisterhu 2014-12-11 01:05:40 UTC
(In reply to Oliver Pinter from comment #27)
> Try this installer: http://www.crysys.hu/~op/freebsd/memstick-debug.img

Default boot gives me EFI framebuffer information, like the original 11-current.
With "mode 3", kernel starts to boot, and then screen goes blank and pc freezes.
The last thing I think can see (It's hard to tell because it goes blank fast) is something like cpu start and virtual memory.
Comment 29 Oliver Pinter freebsd_committer 2014-12-11 13:10:48 UTC
please ping me, and I will create a new set with the workaround, or just try this another installers: http://jenkins.hardenedbsd.org/builds/HardenedBSD_Master/latest-amd64/
Comment 30 Marcus von Appen freebsd_committer freebsd_triage 2015-02-18 11:54:20 UTC
Updated 10.1-BETA and 10.1-RC versioned bugs to 10.1-STABLE.
Comment 31 Greg Rivers 2015-03-15 18:58:54 UTC
See http://lists.freebsd.org/pipermail/freebsd-stable/2015-March/081972.html for details about similar problems with HP EliteBook 850 G1.
Comment 32 Ed Maste freebsd_committer 2015-08-11 17:33:14 UTC
If possible can you please test with the patch in PR 191564
Comment 33 Marcel Moolenaar freebsd_committer 2015-08-12 16:02:35 UTC
This is believed to be fixed for everybody in FreeBSD -current as of today (revision 286667). Please test at your earliest convenience.
Comment 34 Oliver Pinter freebsd_committer 2015-08-13 19:26:14 UTC
Confirmed. The mentioned patch fixed the panic issue with UEFI + CSM mode, but I still have problems with pure UEFI mode.