Bug 194443 - graphics/libdrm: fails to install with MANPAGES option active
Summary: graphics/libdrm: fails to install with MANPAGES option active
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
: 188917 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-18 06:59 UTC by Kurt Jaeger
Modified: 2014-12-24 00:09 UTC (History)
4 users (show)

See Also:
pi: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2014-10-18 06:59:50 UTC
Error: Missing: man/man3/drmAvailable.3.gz
Error: Missing: man/man3/drmHandleEvent.3.gz
Error: Missing: man/man3/drmModeGetResources.3.gz
Error: Missing: man/man7/drm-gem.7.gz
Error: Missing: man/man7/drm-kms.7.gz
Error: Missing: man/man7/drm-memory.7.gz
Error: Missing: man/man7/drm-mm.7.gz
Error: Missing: man/man7/drm-ttm.7.gz
Error: Missing: man/man7/drm.7.gz
Comment 1 Bugzilla Automation freebsd_committer 2014-10-18 06:59:50 UTC
Auto-assigned to maintainer x11@FreeBSD.org
Comment 2 Koop Mast freebsd_committer 2014-10-18 13:20:43 UTC
This is about 2.4.58 correct? I can't reproduce this localy of in poudriere. This might be a docbook issue, can you attach your config.log?
Comment 3 Kurt Jaeger freebsd_committer 2014-10-18 16:51:08 UTC
(In reply to Koop Mast from comment #2)
> This is about 2.4.58 correct?

Yes.

I run daily portupgrades.

> I can't reproduce this localy of in poudriere.
> This might be a docbook issue, can you attach your config.log?

I found why it happens (configure does not detect the manpages stuff):

checking for docbook manpages stylesheet... no

The full make -d all check-plist can be found at:

http://people.freebsd.org/~pi/logs/libdrm-make-d-all.txt

While it finds it when building under poudriere:

checking for docbook manpages stylesheet... yes

So I did this:

cd /usr/ports/textproc/docbook-xsl
make deinstall
make install

and then it worked. Something causes the configure to not see

/usr/local/share/xsl/docbook/manpages/docbook.xsl

even if it's there.
Comment 4 Jean-Sébastien Pédron freebsd_committer 2014-12-23 23:56:57 UTC
Apparently, the problem was some kind of corrupted docbook pacakge?

I'm closing this bug. Please reopen if you think the issue is more general.
Comment 5 Jean-Sébastien Pédron freebsd_committer 2014-12-24 00:09:14 UTC
*** Bug 188917 has been marked as a duplicate of this bug. ***