Bug 194665 - net/aoe and VIMAGE enabled kernel
Summary: net/aoe and VIMAGE enabled kernel
Status: Closed DUPLICATE of bug 194663
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Some People
Assignee: Max Khon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-28 17:10 UTC by Andreas Neiser
Modified: 2014-10-29 14:48 UTC (History)
0 users

See Also:
andreas.neiser: maintainer-feedback? (fjoe)


Attachments
patch aonet.c to compile with -DVIMAGE, does not work! (1.15 KB, patch)
2014-10-28 17:10 UTC, Andreas Neiser
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Neiser 2014-10-28 17:10:58 UTC
Created attachment 148742 [details]
patch aonet.c to compile with -DVIMAGE, does not work!

When building the net/aoe kernel module, loading it into a kernel with VIMAGE support results in the following dmesg error message:

link_elf_obj: symbol ifnet undefined
linker_load_file: Unsupported file type

Of course, kldload is not successful.

I then added to the Makefile of net/aoe (just as a quick try)

CFLAGS+= -DVIMAGE

and patched aoenet.c to make it compile again, see attachment. This gives the following dmesg output when loading:

aoe: aoenet_init: ifp->if_input != ether_input
aoe: aoe_loader: AoE version 1.2.0 initialized

But after some minutes, the system crashes and reboots. So far, I was not able to get a kernel error message. If anyone knows how to patch aoenet.c properly to work with -DVIMAGE, this would help I guess. I'm just a FreeBSD beginner!

Thanks!

By the way: I'm doing this on a FreeNAS 9.2.1.8 machine (based on FreeBSD 9.2.1), since aoe would be nice there...
Comment 1 Bugzilla Automation freebsd_committer 2014-10-28 17:10:58 UTC
Auto-assigned to maintainer fjoe@FreeBSD.org
Comment 2 Andreas Neiser 2014-10-29 14:48:07 UTC

*** This bug has been marked as a duplicate of bug 194663 ***