Bug 194717 - [PATCH] databases/sqlite3 fix readline dependency on head
Summary: [PATCH] databases/sqlite3 fix readline dependency on head
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
: 194716 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-31 16:55 UTC by Guido Falsi
Modified: 2014-11-01 10:38 UTC (History)
1 user (show)

See Also:


Attachments
Fix (1.57 KB, patch)
2014-10-31 16:56 UTC, Guido Falsi
madpilot: maintainer-approval? (pavelivolkov)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2014-10-31 16:55:34 UTC
On FreeBSD 11 readline library is not installed anymore on system since r268461 [1].

This causes readline functionality to not be available on FreeBSD 11 in the sqlite3 command line tool. To fix this I have added a READLINE option to the port, which leverages the readline USES to fix this.

I enabled the option by defualt as a POLA for previous FreeBSD releases, where it is a noop anyway.

While here I also noticed the port needs the ncurses USES too, which I added.
Comment 1 Bugzilla Automation freebsd_committer 2014-10-31 16:55:34 UTC
Maintainer CC'd
Comment 2 Guido Falsi freebsd_committer 2014-10-31 16:56:30 UTC
Created attachment 148826 [details]
Fix
Comment 3 Guido Falsi freebsd_committer 2014-10-31 16:58:11 UTC
*** Bug 194716 has been marked as a duplicate of this bug. ***
Comment 4 Guido Falsi freebsd_committer 2014-10-31 17:06:51 UTC
(In reply to Guido Falsi from comment #0)
> On FreeBSD 11 readline library is not installed anymore on system since
> r268461 [1].

Forgot the reference:

https://svnweb.freebsd.org/base?view=revision&revision=268461
Comment 5 Pavel Volkov 2014-11-01 08:42:15 UTC
Hello. I approve it. Thank you.
Comment 6 Guido Falsi freebsd_committer 2014-11-01 10:37:22 UTC
Committed. Thanks.
Comment 7 commit-hook freebsd_committer 2014-11-01 10:38:06 UTC
A commit references this bug:

Author: madpilot
Date: Sat Nov  1 10:37:07 UTC 2014
New revision: 372001
URL: https://svnweb.freebsd.org/changeset/ports/372001

Log:
  Add READLINE option and conditionally add readline to USES, this
  fixes command line editing on head, which does not install libreadline
  anymore in base.

  While heere also add ncurses USES.

  PR:		194717
  Submitted by:	me
  Approved by:	Pavel Volkov <pavelivolkov at gmail.com> (maintainer)

Changes:
  head/databases/sqlite3/Makefile