Bug 195249 - net/asterisk11 fails to configure within jail
Summary: net/asterisk11 fails to configure within jail
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-21 16:11 UTC by blacktux82
Modified: 2014-11-26 10:40 UTC (History)
1 user (show)

See Also:
blacktux82: maintainer-feedback? (madpilot)


Attachments
Log from configure (827.90 KB, text/x-log)
2014-11-21 16:11 UTC, blacktux82
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description blacktux82 2014-11-21 16:11:37 UTC
Created attachment 149673 [details]
Log from configure

Hello,

I can't compile net/asterisk11 within a jail, outside the jail, the configure works as expected. 

Inside Jail:

checking for LOG_SYSLOG in syslog.h... yes
checking for LOG_UUCP in syslog.h... yes
checking for mandatory modules:  UUID... fail

configure: ***
configure: *** The UUID installation appears to be missing or broken.
configure: *** Either correct the installation, or run configure
configure: *** including --without-uuid.
===>  Script "configure" failed unexpectedly.
Please report the problem to madpilot@FreeBSD.org [maintainer] and attach the
"/usr/ports/net/asterisk11/work/asterisk-11.14.1/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net/asterisk11
*** Error code 1

Stop.
make: stopped in /usr/ports/net/asterisk11

I've attached the config.log. 

Regards, 
André
Comment 1 Bugzilla Automation freebsd_committer 2014-11-21 16:11:37 UTC
Auto-assigned to maintainer madpilot@FreeBSD.org
Comment 2 blacktux82 2014-11-21 16:16:05 UTC
diff Makefile Makefile.save
23,24c23
< #CONFIGURE_ARGS=      --with-uuid=${LOCALBASE}
< CONFIGURE_ARGS=               --disable-uuid
---
> CONFIGURE_ARGS=       --with-uuid=${LOCALBASE}

With --disable-uuid configure works.
Comment 3 Guido Falsi freebsd_committer 2014-11-21 17:30:54 UTC
(In reply to blacktux82 from comment #2)
> diff Makefile Makefile.save
> 23,24c23
> < #CONFIGURE_ARGS=      --with-uuid=${LOCALBASE}
> < CONFIGURE_ARGS=               --disable-uuid
> ---
> > CONFIGURE_ARGS=       --with-uuid=${LOCALBASE}
> 
> With --disable-uuid configure works.

An option can be added to disable UUID if needed. Do you think such an option is required?

Before doing this though, are you sure there is a libuuid correctly installed in the jail? The port should have installed that, but LD is clearly failing to find that. can you check if /usr/local/lib/libuuid.so* (* is wildcard) exists?

can you also send me the output of "pkg info e2fsprogs-libuuid"?

If that port has not been installed in the jail you should investigate why, or why ld fails to find it.

Thanks.
Comment 4 blacktux82 2014-11-24 14:07:59 UTC
Hi,

sorry for late response. ;-)

Interesting:

[root@d22_asterisk2 /usr/ports/misc/e2fsprogs-libuuid]# make

===>  e2fsprogs-libuuid-1.42.12 conflicts with installed package(s): 
      ossp-uuid-1.6.2_7

      They install files into the same place.
      You may want to stop build with Ctrl + C.

(There was a shared lib too...)

Now I've deinstalled ossp-uuid, portmaster will now install misc/e2fsprogs-libuuid. And now the asterisk11 port compiled successfully. :-)

I think the libs has the same name, this should be the problem, I think.
Comment 5 Guido Falsi freebsd_committer 2014-11-25 09:28:45 UTC
(In reply to blacktux82 from comment #4)
> Hi,
> 
> sorry for late response. ;-)
> 
> Interesting:
> 
> [root@d22_asterisk2 /usr/ports/misc/e2fsprogs-libuuid]# make
> 
> ===>  e2fsprogs-libuuid-1.42.12 conflicts with installed package(s): 
>       ossp-uuid-1.6.2_7
> 
>       They install files into the same place.
>       You may want to stop build with Ctrl + C.
> 
> (There was a shared lib too...)
> 
> Now I've deinstalled ossp-uuid, portmaster will now install
> misc/e2fsprogs-libuuid. And now the asterisk11 port compiled successfully.
> :-)
> 
> I think the libs has the same name, this should be the problem, I think.

Yes, this is the cause of the problem.

Looking around it looks like the ossp-libuuid isn't acceptable as a replacement for asterisk, so I'll have to register a conflict with it in the asterisk port.

Maybe also add an option to disable UUID support.

Thanks for the report.
Comment 6 commit-hook freebsd_committer 2014-11-26 10:40:19 UTC
A commit references this bug:

Author: madpilot
Date: Wed Nov 26 10:40:06 UTC 2014
New revision: 373444
URL: https://svnweb.freebsd.org/changeset/ports/373444

Log:
  - Make UUID support an option (enabled by default, no functional
    change in default port)
  - Mark conflict on UUID option with ossp-uuid port, since asterisk
    requires misc/e2fsprogs-libuuid for this functionality and will not
    build if the former is installed.

  Please note that when compiling without UUID support the res_rtp
  module in asterisk will have reduced functionality, so it is suggested
  to keep the option turned on.

  PR:		195249
  Submitted by:	blacktux82 at gmail.com

Changes:
  head/net/asterisk11/Makefile
Comment 7 Guido Falsi freebsd_committer 2014-11-26 10:40:39 UTC
Workaround committed.

Thanks for the report!