Bug 195259 - [MAINTAINER UPDATE]: Update graphics/maim to 2.3.37
Summary: [MAINTAINER UPDATE]: Update graphics/maim to 2.3.37
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Some People
Assignee: Danilo Egea Gondolfo
URL:
Keywords:
: 195125 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-21 20:15 UTC by Neel Chauhan
Modified: 2014-11-22 23:05 UTC (History)
2 users (show)

See Also:
nc: maintainer-feedback+


Attachments
Patch to update graphics/maim to 2.3.37 (863 bytes, patch)
2014-11-21 20:15 UTC, Neel Chauhan
nc: maintainer-approval+
Details | Diff
Poudriere Build Log for graphics/maim 2.3.37 (21.19 KB, text/x-log)
2014-11-21 20:16 UTC, Neel Chauhan
nc: maintainer-approval+
Details
Updated patch for maim-2.3.37 (940 bytes, patch)
2014-11-22 17:58 UTC, Neel Chauhan
nc: maintainer-approval+
Details | Diff
UPDATED Poudriere Build Log for graphics/maim 2.3.37 (19.48 KB, text/x-log)
2014-11-22 17:59 UTC, Neel Chauhan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan freebsd_committer 2014-11-21 20:15:18 UTC
Created attachment 149685 [details]
Patch to update graphics/maim to 2.3.37

I am the maintainer of the port graphics/maim and have a patch to update this port to it's latest version: 2.3.37.
Comment 1 Neel Chauhan freebsd_committer 2014-11-21 20:16:22 UTC
Created attachment 149686 [details]
Poudriere Build Log for graphics/maim 2.3.37

Here is the Poudriere Build Log for graphics/maim 2.3.37
Comment 2 Danilo Egea Gondolfo freebsd_committer 2014-11-22 16:28:34 UTC
*** Bug 195125 has been marked as a duplicate of this bug. ***
Comment 3 Danilo Egea Gondolfo freebsd_committer 2014-11-22 16:34:40 UTC
Is USE_GCC really necessary? I've tried with clang and it works.
Comment 4 Neel Chauhan freebsd_committer 2014-11-22 17:58:46 UTC
Created attachment 149721 [details]
Updated patch for maim-2.3.37

USE_GCC was needed in the past since graphics/maim couldn't compile with Clang in the past. I decided to remove USE_GCC, and this version (2.3.37) built successfully with Clang.

I also uploaded an updated patch without USE_GCC and will upload the Poudriere build log shortly.
Comment 5 Neel Chauhan freebsd_committer 2014-11-22 17:59:44 UTC
Created attachment 149722 [details]
UPDATED Poudriere Build Log for graphics/maim 2.3.37

Here is the Poudriere Build Log without USE_GCC.
-Neel
Comment 6 commit-hook freebsd_committer 2014-11-22 23:03:09 UTC
A commit references this bug:

Author: danilo
Date: Sat Nov 22 23:02:30 UTC 2014
New revision: 373114
URL: https://svnweb.freebsd.org/changeset/ports/373114

Log:
  - Update to 2.3.37
  - Remove USE_GCC

  PR:		195259
  Submitted by:	Neel Chauhan <neel@neelc.org> (maintainer)

Changes:
  head/graphics/maim/Makefile
  head/graphics/maim/distinfo
Comment 7 Danilo Egea Gondolfo freebsd_committer 2014-11-22 23:05:42 UTC
Committed. Thanks!