Bug 195272 - emulators/virtualbox-ose stil uses the value texlive for USE_TEX. This is obsoleted. And at leaset 4.3.18, PDF user manual for fr_FR was removbed.
Summary: emulators/virtualbox-ose stil uses the value texlive for USE_TEX. This is obs...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Some People
Assignee: Jung-uk Kim
URL:
Keywords:
: 193893 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-22 03:58 UTC by SASAKI Katuhiro
Modified: 2014-11-25 06:52 UTC (History)
3 users (show)

See Also:
crest: maintainer-feedback? (vbox)


Attachments
This is a patch for emulators/virtualbox-ose. This removes "USE_TEX= ... texlive" from Makefile and remove "%%MANUAL%%%%DOCSDIR%%/UserManual_fr_FR.pdf" from pkg-plist. (945 bytes, patch)
2014-11-22 03:58 UTC, SASAKI Katuhiro
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description SASAKI Katuhiro 2014-11-22 03:58:42 UTC
Created attachment 149708 [details]
This is a patch for emulators/virtualbox-ose. This removes "USE_TEX= ... texlive" from Makefile and remove "%%MANUAL%%%%DOCSDIR%%/UserManual_fr_FR.pdf" from pkg-plist.

In Makefile of emulators/virtualbox-ose, next lines is now remaind.

.if ${PORT_OPTIONS:MMANUAL}
USE_TEX=	dvipsk:build formats:build texlive
.endif

And in /usr/ports/Mk/bsd.tex.mk, ""texlive" must not be defined in USE_TEX" is indicated.

.if !empty(USE_TEX:tu:MTEXLIVE)
IGNORE=		"texlive" must not be defined in USE_TEX
.endif

So, we must remove "texlive" from USE_TEX, like below.
USE_TEX=	dvipsk:build formats:build

And, after removing texlive from USE_TEX and build emulators/virtualbox, 
file UserManual_fr_FR.pdf was not present.

So, I think attached patch is needed.
Comment 1 Bugzilla Automation freebsd_committer 2014-11-22 03:58:42 UTC
Auto-assigned to maintainer vbox@FreeBSD.org
Comment 2 Jung-uk Kim freebsd_committer 2014-11-24 23:01:15 UTC
I'll take it.
Comment 3 Jung-uk Kim freebsd_committer 2014-11-24 23:14:42 UTC
*** Bug 193893 has been marked as a duplicate of this bug. ***
Comment 4 commit-hook freebsd_committer 2014-11-25 00:40:29 UTC
A commit references this bug:

Author: jkim
Date: Tue Nov 25 00:40:20 UTC 2014
New revision: 373388
URL: https://svnweb.freebsd.org/changeset/ports/373388

Log:
  - Update to 4.3.20.
  - Fix MANUAL option. [1]

  PR:		195272 [1]

Changes:
  head/emulators/virtualbox-ose/Makefile
  head/emulators/virtualbox-ose/distinfo
  head/emulators/virtualbox-ose/files/patch-src-VBox-Additions-x11-vboxvideo-Makefile.kmk
  head/emulators/virtualbox-ose/files/patch-src-VBox-Devices-USB-freebsd-USBProxyDevice-freebsd.cpp
  head/emulators/virtualbox-ose/pkg-plist
  head/emulators/virtualbox-ose-additions/Makefile
  head/emulators/virtualbox-ose-additions/distinfo
  head/emulators/virtualbox-ose-kmod/Makefile
  head/emulators/virtualbox-ose-kmod/distinfo
Comment 5 Jung-uk Kim freebsd_committer 2014-11-25 00:42:45 UTC
Committed (r373388), thanks!
Comment 6 Hans Petter Selasky freebsd_committer 2014-11-25 06:52:50 UTC
Hi,

Looking at:

https://svnweb.freebsd.org/ports/head/emulators/virtualbox-ose/files/patch-src-VBox-Devices-USB-freebsd-USBProxyDevice-freebsd.cpp?revision=373388&view=markup


I think you should set cMillies = 0, right
after RTPipeRead(pDevFBSD->hPipeWakeupR, &bRead, 1, &cbIgnored), so that the function actually returns when the hPipeWakeupR is signalled. I think the purpose of the hPipeWakeupR is to force the reaper to return to the caller.


Else it looks good!

Test with a USB webcam, USB audio device and/or a USB memory stick and it should be fine.

--HPS