Bug 195975 - [NEW PORT] games/unteralterbach: Visual novel satire on pedohysteric society
Summary: [NEW PORT] games/unteralterbach: Visual novel satire on pedohysteric society
Status: Closed Not Accepted
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on: 195768
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-14 18:38 UTC by Jan Beich
Modified: 2016-03-09 03:48 UTC (History)
2 users (show)

See Also:


Attachments
shar, v1 (2.20 KB, text/plain)
2014-12-14 18:38 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (9.3R i386) (24.73 KB, text/plain)
2014-12-14 18:40 UTC, Jan Beich
no flags Details
shar, v1.1 (2.46 KB, text/plain)
2014-12-24 16:02 UTC, Jan Beich
no flags Details
shar, v2, _all.zip variant (72.99 KB, text/plain)
2015-03-19 11:10 UTC, Jan Beich
no flags Details
|poudriere bulk -t| log for 10.1R i386, _all.zip variant (26.28 KB, text/plain)
2015-03-19 11:11 UTC, Jan Beich
no flags Details
shar, v2, _all.zip variant (2.35 KB, text/plain)
2015-03-19 11:13 UTC, Jan Beich
no flags Details
shar, v1, _source.zip variant (incompatible saves) (3.29 KB, text/plain)
2015-03-20 08:30 UTC, Jan Beich
no flags Details
|poudriere bulk -t| log for 10.1R i386, _source.zip variant (29.94 KB, text/plain)
2015-03-20 08:34 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-12-14 18:38:58 UTC
Created attachment 150580 [details]
shar, v1

$ cat pkg-descr
In the game the player slips into the role of Bernd, who relocates
from the big city to the bavarian backwoods. The first time on his own
in his life, he gets a job at the Federal Office for the
Implementation of the Oktoberfest...

WWW: http://unteralterbach.net/
Comment 1 Jan Beich freebsd_committer 2014-12-14 18:40:39 UTC
Created attachment 150581 [details]
|poudriere testport -P| log (9.3R i386)
Comment 2 Jan Beich freebsd_committer 2014-12-24 16:02:55 UTC
Created attachment 150940 [details]
shar, v1.1

- add a comment about the --savedir workaround
- embed PORTVERSION to --savedir as updates maybe incompatible
- improve description based on games.renpy.org
- mark RESTRICTED to sidestep landmines noted in Debian review[1]

[1] https://lists.debian.org/debian-legal/2014/03/msg00017.html
Comment 3 Dmitry Marakasov freebsd_committer 2015-03-17 19:09:46 UTC
- Please use COPYTREE_SHARE instead of tar in installation.
- I don't really like --savedir thingy. First, it includes port version on the basis that save cames may be incompatible, however if they are compatible, player progress will still be lost unless savegames are manually copied. To fix that, it'd probably be better to not tie it to PORTVERSION, but to maintain a separate variabled with lowest version current one is savegame-compatible with.

Otherwise looks good.
Comment 4 Dmitry Marakasov freebsd_committer 2015-03-18 05:09:55 UTC
Also, website mentions GPL3. Shouldn't it be added to LICENSE?
Comment 5 Jan Beich freebsd_committer 2015-03-19 11:10:51 UTC
Created attachment 154508 [details]
shar, v2, _all.zip variant

- Simplify DOCS install
- Prefer COPYTREE_SHARE without MKDIR before
- Drop PORTREVISION from --savedir hack

(In reply to Dmitry Marakasov from comment #3)
> Also, website mentions GPL3. Shouldn't it be added to LICENSE?

WWW mentions two sets of licenses. However, after extracting _source.zip
and checking with `unrpa 001.rpa` I could only find the following:

    # game/script.rpy:17796
    old "Dieses Spiel und alle enthaltenen Texte und Ton- und Bild-Dokumente{p}sind lizenziert unter einer {b}CC BY-NC-ND 3.0{/b} Lizenz.{p}"
    new "This game and all contained text and audio and video documents{p}are licensed under the {b}CC BY-NC-ND 3.0{/b} license.{p}"

which is kinda different from

  The source code is released under CC BY-SA 3.0 Unported and GPLv3.

and more in line with

  The game was developed with Ren'Py and is available under the
  CC BY-NC-ND 3.0 Unported license.
Comment 6 Jan Beich freebsd_committer 2015-03-19 11:11:02 UTC
Created attachment 154509 [details]
|poudriere bulk -t| log for 10.1R i386, _all.zip variant
Comment 7 Jan Beich freebsd_committer 2015-03-19 11:13:23 UTC
Created attachment 154510 [details]
shar, v2, _all.zip variant

Oops, prune .git directory.
Comment 8 Jan Beich freebsd_committer 2015-03-20 08:30:35 UTC
Created attachment 154556 [details]
shar, v1, _source.zip variant (incompatible saves)

While achievements and preferences usually load without issues routes
progression in save slots ends up screwed. It appears Ren'Py 6.18.3
bytecode in _all.zip built on Windows isn't compatible with custom builds
from _source.zip. Confirmed with Android build of the game.

However, the port sheds light on why --savedir hack was required for
_all.zip version and installs better looking 128x128 icon.
Comment 9 Jan Beich freebsd_committer 2015-03-20 08:34:04 UTC
Created attachment 154558 [details]
|poudriere bulk -t| log for 10.1R i386, _source.zip variant

build_fs_violation due to rebuild of bytecode for devel/renpy itself.

====>> Checking for filesystem violations... done
====>> Error: Filesystem touched during build:
usr/local/share/renpy/renpy/common/000atl.rpyc:
        size (407, 409)
usr/local/share/renpy/renpy/common/00action_file.rpyc:
        size (4201, 4231)
usr/local/share/renpy/renpy/common/00build.rpyc:
        size (2649, 2670)
usr/local/share/renpy/renpy/common/00obsolete.rpyc:
        size (1286, 1312)
usr/local/share/renpy/renpy/common/00gltest.rpyc:
        size (6553, 6578)
usr/local/share/renpy/renpy/common/00gamemenu.rpyc:
        size (3635, 3664)
extra: usr/local/share/renpy/renpy/common/_layout/screen_load_save.rpymc
extra: usr/local/share/renpy/renpy/common/_layout/screen_yesno_prompt.rpymc
usr/local/share/renpy/renpy/common/_layout/classic_navigation.rpymc:
        size (805, 830)
...
Comment 10 Martin Wilke freebsd_committer 2016-01-18 06:35:44 UTC
Hi,

Any progress here?
Comment 11 Dmitry Marakasov freebsd_committer 2016-02-19 14:48:55 UTC
The port itself is OK, but I think I can't take responsibility in committing it due no the nature of the content.
Comment 12 Jan Beich freebsd_committer 2016-03-09 03:48:21 UTC
Deferred indefinitely for non-technical reasons. Having just one example of a friendly-licensed renpy game in ports is probably enough for regress-testing the engine. Other games can be launched as follows:

  $ renpy /path/to/game

Besides, big packages are frowned upon, especially NO_BUILD ones. If they're later marked with MANUAL_PACKAGE_BUILD having a port doesn't bring a lot of benefit unless installation or launch is non-trivial.