Bug 195993 - graphics/inkscape linking fails when ImageMagick has compiled w/ openmp
Summary: graphics/inkscape linking fails when ImageMagick has compiled w/ openmp
Status: Closed DUPLICATE of bug 194760
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-15 11:30 UTC by Sungyoung lee
Modified: 2015-10-28 20:04 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sungyoung lee 2014-12-15 11:30:13 UTC
When compiling inkscape-0.48.4_8 from ports under an installation of ImageMagick w/ openmp,linking stage fails w/ the below message.

3 warnings generated.
  AR     libinkscape.a
2 warnings generated.
  CXXLD  inkscape
  CXXLD  inkview
libinkscape.a(imagemagick.o): In function `Inkscape::Extension::Internal::Bitmap::ImageMagickDocCache::readImage(char const*, Magick::Image*)':
extension/internal/bitmap/imagemagick.cpp:(.text+0x262): undefined reference to `Magick::Blob::base64(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >)'
extension/internal/bitmap/imagemagick.cpp:(.text+0x2ca): undefined reference to `Magick::Image::read(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)'
libinkscape.a(imagemagick.o): In function `Inkscape::Extension::Internal::Bitmap::ImageMagickDocCache::readImage(char const*, Magick::Image*)':
extension/internal/bitmap/imagemagick.cpp:(.text+0x262): undefined reference to `Magick::Blob::base64(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >)'
extension/internal/bitmap/imagemagick.cpp:(.text+0x2ca): undefined reference to `Magick::Image::read(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)'
c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[4]: *** [inkscape] Error 1
gmake[4]: *** Waiting for unfinished jobs....
c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[4]: *** [inkview] Error 1
gmake[4]: Leaving directory `/usr/ports/graphics/inkscape/work/inkscape-0.48.4/src'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/graphics/inkscape/work/inkscape-0.48.4'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/graphics/inkscape/work/inkscape-0.48.4'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

after deinstalling ImageMagick and installing again it w/o openmp and compile, it works fine.
Comment 1 John Marino freebsd_committer 2015-02-06 17:23:57 UTC
auto-assign failed due to original title, assign to gnome@ now.
Comment 2 Friedrich Volkmann 2015-02-25 16:23:41 UTC
This is a duplicate to #194760 (which is, however, more messy).
Comment 3 Kurt Jaeger freebsd_committer 2015-10-28 20:04:39 UTC

*** This bug has been marked as a duplicate of bug 194760 ***