Bug 196032 - graphics/netpbm: Appears to need MAKE_JOBS_UNSAFE=yes
Summary: graphics/netpbm: Appears to need MAKE_JOBS_UNSAFE=yes
Status: Closed DUPLICATE of bug 192857
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2014-12-16 17:56 UTC by Don Lewis
Modified: 2014-12-27 09:58 UTC (History)
0 users

See Also:
dinoex: maintainer-feedback-


Attachments
patch to add MAKE_JOBS_UNSAFE=yes to netpbm Makefile. (391 bytes, patch)
2014-12-16 17:56 UTC, Don Lewis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Don Lewis freebsd_committer 2014-12-16 17:56:06 UTC
Created attachment 150648 [details]
patch to add MAKE_JOBS_UNSAFE=yes to netpbm Makefile.

When using poudriere to build netpbm with ALLOW_MAKE_JOBS=yes, the build fails with these errors:

gmake[2]: Leaving directory '/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/buildtools'
mkdir -p importinc
ilrm -f importinc/bitreverse.h
ln -sf /wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/lib/util/../../lib/lum.h importinc/lum.h
mkdir -p importinc
e not recognized: File truncated
/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/buildtools/Makefile:40: recipe for target 'typegen' failed
gmake[2]: *** [typegen] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/buildtools'
GNUmakefile:119: recipe for target '/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/buildtools/typegen' failed
gmake[1]: *** [/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/buildtools/typegen] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94'
/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/lib/util/../../Makefile.common:176: recipe for target '/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/lib/util/../../pm_config.h' failed
gmake: *** [/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/lib/util/../../pm_config.h] Error 2
gmake: *** Waiting for unfinished jobs....
gmake[2]: Leaving directory '/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/buildtools'
/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/buildtools/typegen >inttypes_netpbm.h || (rm -f inttypes_netpbm.h || false)
ln -sf /wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/lib/util/../../lib/util/bitreverse.h importinc/bitreverse.h
rm -f importinc/mallocvar.h
/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/buildtools/typegen: not found
ln -sf /wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94/lib/util/../../lib/util/mallocvar.h importinc/mallocvar.h
gmake[1]: Leaving directory '/wrkdirs/usr/ports/graphics/netpbm/work/netpbm-10.35.94'
[: xTry: unexpected operator
*** Error code 1

Stop in /usr/ports/graphics/netpbm.
Comment 1 Bugzilla Automation freebsd_committer 2014-12-16 17:56:06 UTC
Auto-assigned to maintainer dinoex@FreeBSD.org
Comment 2 commit-hook freebsd_committer 2014-12-27 09:42:35 UTC
A commit references this bug:

Author: dinoex
Date: Sat Dec 27 09:41:41 UTC 2014
New revision: 375675
URL: https://svnweb.freebsd.org/changeset/ports/375675

Log:
  - add MAKE_JOBS_UNSAFE
  PR:		192857
  Submitted by:	Matthias Andree

  PR:		196032

Changes:
  head/graphics/netpbm/Makefile
Comment 3 Dirk Meyer freebsd_committer 2014-12-27 09:58:25 UTC

*** This bug has been marked as a duplicate of bug 192857 ***