Bug 196617 - textproc/dblatex can not be invoked
Summary: textproc/dblatex can not be invoked
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-12 17:37 UTC by holger
Modified: 2015-05-17 16:45 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description holger 2015-01-12 17:37:44 UTC
$ dblatex 
env: python: No such file or directory

dblatex is a script and the shebang invokes python and not python2/python2.7.
The file could probably be patched through:

 python_OLD_CMD=    /usr/bin/env python
 python_CMD=    ${PYTHON_CMD}
 SHEBANG_FILES= bin/dblatex

I am not sure if that is the right way to go.
Comment 1 Gavin Atkinson freebsd_committer freebsd_triage 2015-01-12 18:48:55 UTC
Hi,

Due to an issue with the backend FreeBSD Bugzilla database, your original PR and any updates to it since have been lost.  I've recreated the original PR as best as I can, however any attachments and updates you submitted to the PR have been lost.  Please could you resubmit them?

Thanks, and apologies.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2015-01-15 01:12:07 UTC
Fix Summary and notiy maintainer.
Comment 3 John Marino freebsd_committer 2015-05-17 15:11:09 UTC
The maintainer is gone.  With this PR, that makes 4 consecutive timeouts.
Comment 4 John Marino freebsd_committer 2015-05-17 15:12:13 UTC
I'll reset the port and try to fix this if I can confirm.
Comment 5 commit-hook freebsd_committer 2015-05-17 16:32:24 UTC
A commit references this bug:

Author: marino
Date: Sun May 17 16:31:52 UTC 2015
New revision: 386630
URL: https://svnweb.freebsd.org/changeset/ports/386630

Log:
  textproc/dblatex: Fix failure to invoke, reset maintainer

  The shebang "env python" won't work.  Normally shebangfix would be used
  to fix this, but dblatex is actually built so we need to use sed in the
  post-install target to adjust it.

  While here, reset the maintainer.  This PR is the fourth consecutive
  timeout.  Also clean up the port.

  PR:		196617
  Submitted by:	holger (freyther.de)

Changes:
  head/textproc/dblatex/Makefile
  head/textproc/dblatex/pkg-descr
Comment 6 John Marino freebsd_committer 2015-05-17 16:33:43 UTC
This was surprisingly painful to fix.  shebangfix did not work and it takes a long time to build this port due to tex extraction.  I had to do it many times.
Comment 7 holger 2015-05-17 16:45:51 UTC
Thank you.