Bug 196820 - IBM x3650, ServeRAID M5110e, volumes corrupted after boot with mrsas driver
Summary: IBM x3650, ServeRAID M5110e, volumes corrupted after boot with mrsas driver
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.1-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-17 08:45 UTC by Michael
Modified: 2015-01-17 09:36 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2015-01-17 08:45:45 UTC
On my IBM x3650 M4, running FreeBSD 10.1-RELEASE I'm using the mfi driver with the builtin M5110e RAID controller. Then I thought to try the mrsas driver even the M5110e is not listed in the documentation. I set the 

  hw.mfi.mrsas_enable=1

flag at the loader prompt. Then FreeBSD started, the volumes where listed as da* devices but I was not able to mount the root filesystem. Then I started the machine again with mfi enabled. But then I noticed that all volumes are corrupted, which means that even the GPT was gone. 

The problem seems to be reproducible: A second try had the same result.

I don't know if it's intended that the M5110 should run with mrsas. If not, it should not damage the volumes. At least there should be a clear warning in the man page.

The machine is not in production use at the moment, so I can do more testing if required.

Michael