Bug 196842 - [patch] textproc/discount installs broken manpages
Summary: [patch] textproc/discount installs broken manpages
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Julien Laffaye
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-18 16:59 UTC by Adam Weinberger
Modified: 2015-02-22 15:29 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (jlaffaye)


Attachments
install discount manpages as symlinks (1.81 KB, patch)
2015-01-18 16:59 UTC, Adam Weinberger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Weinberger freebsd_committer 2015-01-18 16:59:34 UTC
Created attachment 151800 [details]
install discount manpages as symlinks

textproc/discount installs a number of broken manpages, such as:

[adamw@apnoea ~] man mkd_css
<standard input>:2: can't open `man3/mkd-functions.3': No such file or directory

The problem is that the Makefile is using the non-standard groff '.so' command to include another file, which doesn't behave the same for us.

The attached patch just creates the manpages as symlinks.
Comment 1 Bugzilla Automation freebsd_committer 2015-01-18 16:59:34 UTC
Auto-assigned to maintainer jlaffaye@FreeBSD.org
Comment 2 Adam Weinberger freebsd_committer 2015-02-22 15:28:45 UTC
Committed. There's a new version out by the way.
Comment 3 commit-hook freebsd_committer 2015-02-22 15:29:05 UTC
A commit references this bug:

Author: adamw
Date: Sun Feb 22 15:28:27 UTC 2015
New revision: 379614
URL: https://svnweb.freebsd.org/changeset/ports/379614

Log:
  A number of the discount manpages are broken due to FreeBSD's lack of support of
  the .so macro. I know that work has been done on this in base, but for now fix
  discount's manpages by installing them as symlinks instead.

  PR:		196842
  Approved by:	maintainer timeout (> 1 month)

Changes:
  head/textproc/discount/Makefile
  head/textproc/discount/files/
  head/textproc/discount/files/patch-Makefile.in