Bug 196858 - x11-drivers/xorg-drivers: fix creeping dependency on x11-drivers/xf86-video-ati in tier-2
Summary: x11-drivers/xorg-drivers: fix creeping dependency on x11-drivers/xf86-video-a...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-19 00:29 UTC by Mark Linimon
Modified: 2015-02-23 14:36 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
patch for x11-drivers/xorg-drivers/Makefile (1.22 KB, patch)
2015-01-19 00:29 UTC, Mark Linimon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2015-01-19 00:29:04 UTC
Created attachment 151813 [details]
patch for x11-drivers/xorg-drivers/Makefile

[originally posted on 2015011 to mailing list while bugzilla was down]

It looks like for !(i386/amd64) builds that an uncessary dependency on
the above has crept in.  In that driver's Makefile we see

  # No Radeon kernel driver on non-x86 and PC98.
  ONLY_FOR_ARCHS= i386 amd64

but it's still depended on by default in x11-drivers/xorg-drivers/Makefile .

I think the following fix is needed -- but is it complete?
Comment 1 Bugzilla Automation freebsd_committer 2015-01-19 00:29:04 UTC
Auto-assigned to maintainer x11@FreeBSD.org
Comment 2 Sean Bruno freebsd_committer 2015-02-19 16:27:59 UTC
Confirmed needed for armv6.

http://chips.ysv.freebsd.org/build.html?mastername=11armv6-11armv6&build=2015-02-12_15h33m26s

Skipping the other drivers because the ATI driver is unavailable for armv6.  I'm not sure that we *need* any of the drivers in this package, but this is a proper depend in my opinion.
Comment 3 commit-hook freebsd_committer 2015-02-23 14:35:33 UTC
A commit references this bug:

Author: linimon
Date: Mon Feb 23 14:34:46 UTC 2015
New revision: 379680
URL: https://svnweb.freebsd.org/changeset/ports/379680

Log:
  Move ATI driver to be specific to x86.  This fixes the xorg build for arm
  and sparc64.

  PR:		196858
  Submitted by:	linimon
  Reviewed by:	sbruno
  Approved by:	maintainer timeout

Changes:
  head/x11-drivers/xorg-drivers/Makefile
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2015-02-23 14:36:04 UTC
Committed via maintainer-timeout after cursory review by portmgr.  Tested on amd64, arm, sparc64.