Bug 197137 - benchmarks/netperf: Enable OMNI by default
Summary: benchmarks/netperf: Enable OMNI by default
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Marius Strobl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-27 20:49 UTC by Marcel Moolenaar
Modified: 2015-01-27 22:57 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (marius)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Moolenaar freebsd_committer 2015-01-27 20:49:31 UTC
The netperf package is incompatible with non-FreeBSD netperf installations. The error on NetBSD or Ubuntu is:

marcel@ubuntu:~$ netperf -H 192.168.160.172
MIGRATED TCP STREAM TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to 192.168.160.172 () port 0 AF_INET : demo
Unknown error 998
netperf: remote error 998

The problem is caused by FreeBSD's netperf port having OMNI disabled by default. Apparently this introduces a compatibility problem. The FreeBSD netperf can communicate with a non-FreeBSD netperf, so it appears to be a one-way incompatibility.

The fix is to build the netperf port by hand with OMNI enabled. Given that OMNI is enabled by default since netperf 2.5, it's not clear why FreeBSD keeps it disabled. Especially since it breaks interoperability OOTB. A better default is to have OMNI enabled...
Comment 1 Bugzilla Automation freebsd_committer 2015-01-27 20:49:31 UTC
Auto-assigned to maintainer marius@FreeBSD.org
Comment 2 commit-hook freebsd_committer 2015-01-27 22:56:25 UTC
A commit references this bug:

Author: marius
Date: Tue Jan 27 22:56:15 UTC 2015
New revision: 378027
URL: https://svnweb.freebsd.org/changeset/ports/378027

Log:
  Enable OMNI by default; this matches what vanilla netperf does since
  version 2.5 and restores bidirectional compatibility with other OS
  distributions following suit.

  PR:		197137

Changes:
  head/benchmarks/netperf/Makefile