Bug 197301 - sysutils/fusefs-ntfs: Remove block device check in mkntfs
Summary: sysutils/fusefs-ntfs: Remove block device check in mkntfs
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-03 22:50 UTC by darius
Modified: 2017-12-17 07:14 UTC (History)
2 users (show)

See Also:


Attachments
Fix bug (935 bytes, patch)
2015-02-03 22:50 UTC, darius
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description darius 2015-02-03 22:50:14 UTC
Created attachment 152530 [details]
Fix bug

mkntfs complains if a device node is not a block device which is nonsensical in FreeBSD.

This patch removes the test so it works without -F.
Comment 1 Kurt Jaeger freebsd_committer 2015-10-17 19:35:38 UTC
We assume that the -F option is sufficient to use mkntfs.
Comment 2 darius 2015-10-18 07:12:32 UTC
"Works as intended" means you always have to use -F? This seems user hostile :(
Comment 3 Kurt Jaeger freebsd_committer 2015-10-18 08:29:27 UTC
You are right, it is useful to apply this patch. But it should also be upstreamed.

I tried to submit it upstream, but there's a rate limiting active there. Waiting...
Comment 4 commit-hook freebsd_committer 2015-10-18 08:50:51 UTC
A commit references this bug:

Author: pi
Date: Sun Oct 18 08:49:58 UTC 2015
New revision: 399607
URL: https://svnweb.freebsd.org/changeset/ports/399607

Log:
  sysutils/fusefs-ntfs: patch mkntfs to not check for block devices

  PR:		197301
  Submitted by:	darius@dons.net.au

Changes:
  head/sysutils/fusefs-ntfs/Makefile
  head/sysutils/fusefs-ntfs/files/patch-ntfsprogs_mkntfs.c
Comment 5 Kurt Jaeger freebsd_committer 2015-10-18 08:56:20 UTC
Committed, thanks.
Comment 6 Kurt Jaeger freebsd_committer 2015-10-18 18:33:01 UTC
Upstream discussion see 

http://tuxera.com/forum/viewtopic.php?f=5&t=31008
Comment 7 vali gholami 2017-12-17 07:14:45 UTC
MARKED AS SPAM