Bug 197515 - textproc/colordiff looks for colordiffrc in /etc rather than /usr/local/etc
Summary: textproc/colordiff looks for colordiffrc in /etc rather than /usr/local/etc
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Emanuel Haupt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-10 13:30 UTC by Moritz Wilhelmy
Modified: 2015-02-10 13:45 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ehaupt)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Wilhelmy 2015-02-10 13:30:43 UTC
/usr/local/bin/colordiff:67:my $etcdir = '/etc';

The config file is installed in /usr/local/etc as intended, but colordiff doesn't look there at all.
Comment 1 Bugzilla Automation freebsd_committer 2015-02-10 13:30:43 UTC
Auto-assigned to maintainer ehaupt@FreeBSD.org
Comment 2 Emanuel Haupt freebsd_committer 2015-02-10 13:45:46 UTC
Fix committed, thanks!
Comment 3 commit-hook freebsd_committer 2015-02-10 13:45:49 UTC
A commit references this bug:

Author: ehaupt
Date: Tue Feb 10 13:45:14 UTC 2015
New revision: 378777
URL: https://svnweb.freebsd.org/changeset/ports/378777

Log:
  Fix config file search patch.

  PR:		197515 (based on)
  Submitted by:	mw+freebsd@barfooze.de

Changes:
  head/textproc/colordiff/Makefile