Bug 198439 - [maintainer update] x11-fm/doublecmd: update to version 0.6.0
Summary: [maintainer update] x11-fm/doublecmd: update to version 0.6.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-08 23:17 UTC by Beñat Gonzalez Etxepare
Modified: 2015-03-22 19:36 UTC (History)
3 users (show)

See Also:


Attachments
Patch to version 0.6.0 (4.93 KB, patch)
2015-03-08 23:17 UTC, Beñat Gonzalez Etxepare
no flags Details | Diff
Patch to version 0.6.0 (fixed) (5.35 KB, patch)
2015-03-13 18:40 UTC, Beñat Gonzalez Etxepare
no flags Details | Diff
doublecmd-0.6.0 poudriere log (8.06 KB, text/plain)
2015-03-14 12:30 UTC, Beñat Gonzalez Etxepare
no flags Details
Poudriere log file (268.58 KB, text/plain)
2015-03-14 12:33 UTC, Beñat Gonzalez Etxepare
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Beñat Gonzalez Etxepare 2015-03-08 23:17:18 UTC
Created attachment 154043 [details]
Patch to version 0.6.0

Changes:
- Update to version 0.6.0. List of changes:
http://doublecmd.sourceforge.net/mediawiki/index.php/Changes_in_version_0.6.0
- Removed wcx_lzma plugin
- Added new wcx_unbz2 plugin

New files:
- files/patch-src_platform_uosforms.pas


Tested using Poudriere.
Comment 1 Bartek Rutkowski freebsd_committer 2015-03-13 10:59:54 UTC
Hi,

During the testing, the build fails due to orphaned directory:

http://pd.valinor.palantiri.org/data/84amd64-default/2015-03-13_11h17m48s/logs/errors/doublecmd-0.6.0.log

If you can send a patch that fixes that problem, I can test it and commit if if it will be ok.

Kind regards,
Bartek Rutkowski
Comment 2 Beñat Gonzalez Etxepare 2015-03-13 18:40:46 UTC
Created attachment 154272 [details]
Patch to version 0.6.0 (fixed)

Sorry, I didn't test it with default options, and this error didn't show up.
This new patch fixes the problem. Thanks!
Comment 3 Bartek Rutkowski freebsd_committer 2015-03-14 08:32:46 UTC
Your latest patch fails in a different way, during the patching build phase:

http://pd.valinor.palantiri.org/data/84amd64-default/2015-03-14_09h28m48s/logs/errors/doublecmd-0.6.0.log
Comment 4 Beñat Gonzalez Etxepare 2015-03-14 12:30:29 UTC
Created attachment 154293 [details]
doublecmd-0.6.0 poudriere log

I can't reproduce the error, as you can see in my attached log file it passes the patching phase cleanly.

Was the second patch I submitted applied cleanly against the current version in the ports tree (0.5.11), or was there any error?
Comment 5 Beñat Gonzalez Etxepare 2015-03-14 12:33:03 UTC
Created attachment 154294 [details]
Poudriere log file

Sorry, uploaded your log file instead of mine in the previous comment. This is my log file.
Comment 6 Bartek Rutkowski freebsd_committer 2015-03-16 11:13:25 UTC
Currently, the port fails to build because of errors during patch phase: http://pd.valinor.palantiri.org/data/84amd64-default/2015-03-16_12h11m22s/logs/errors/doublecmd-0.6.0.log
Comment 7 Beñat Gonzalez Etxepare 2015-03-16 22:19:18 UTC
Can you confirm you have the following files and checksums after applying the patch to version 0.6.0?

SHA256 (./Makefile) = 0f8e47fd3f7e6bc21891e6c569d5557e6ac5486f1f7bc786ed1d77493329aad4
SHA256 (./distinfo) = f09d629cb90ab02abb92667ff3e74a3fafeda67ea7e9e57902156e3feab83bde
SHA256 (./files/patch-plugins__wlx__WlxMplayer__src__wlxMplayer.lpr) = 1b97ea678a9d172dc69e2bb91949c665d0801581621553334c1503a011036c1d
SHA256 (./files/patch-src__dmhelpmanager.pas) = 4b56a793c20d10a0bb824b6e97adee966d2ca849fc345d7a896f4b97f1fca06e
SHA256 (./files/patch-src__uGlobsPaths.pas) = cf3822738d0344c8b234b54cdadb300841bb186f59aa3ebb9a28772a14381b57
SHA256 (./files/patch-src_platform_uosforms.pas) = 794e2dbbc026f05190feca2ac380dc24580adf86494630e93799bd893fa47cb3
SHA256 (./pkg-descr) = a6bb8d790b087e3328e939d8733757bf6edab51007915d4e498011da6fe0e024
Comment 8 Bartek Rutkowski freebsd_committer 2015-03-21 09:40:12 UTC
Here's how the build is failing:

http://pd.valinor.palantiri.org/data/84amd64-default/2015-03-21_09h35m26s/logs/errors/doublecmd-0.6.0.log

and here are the checksums of the files after patching:

pd# find . | xargs sha256
SHA256 (.) = 287a3387a6a65e0b5483d02992ed2649ef4a9f48d79c7c1d3484acfaec7367d3
SHA256 (./distinfo) = f09d629cb90ab02abb92667ff3e74a3fafeda67ea7e9e57902156e3feab83bde
SHA256 (./files) = 36c159d76b52e03e496363607c5940227f62f4e048df344b050159bc97bba3d7
SHA256 (./files/patch-plugins__wlx__WlxMplayer__src__wlxMplayer.lpr) = 1b97ea678a9d172dc69e2bb91949c665d0801581621553334c1503a011036c1d
SHA256 (./files/patch-src__uGlobsPaths.pas) = cf3822738d0344c8b234b54cdadb300841bb186f59aa3ebb9a28772a14381b57
SHA256 (./files/patch-src__dmhelpmanager.pas) = 4b56a793c20d10a0bb824b6e97adee966d2ca849fc345d7a896f4b97f1fca06e
SHA256 (./files/patch-src_platform_uosforms.pas) = 9771675ec92707f0245aa8556fbb21308fc28c7eeef906358f6fd92d1f622f7e
SHA256 (./Makefile) = 0f8e47fd3f7e6bc21891e6c569d5557e6ac5486f1f7bc786ed1d77493329aad4
SHA256 (./pkg-descr) = a6bb8d790b087e3328e939d8733757bf6edab51007915d4e498011da6fe0e024
Comment 9 Beñat Gonzalez Etxepare 2015-03-21 13:00:43 UTC
Are you sure you are applying the patch in a clean checkout? The file "files/patch-src_platform_uosforms.pas" should not exists before patching, and the resulting file's checksum should be 794e2dbbc026f05190feca2ac380dc24580adf86494630e93799bd893fa47cb3.

I can't reproduce your results.
Comment 10 commit-hook freebsd_committer 2015-03-22 19:33:27 UTC
A commit references this bug:

Author: riggs
Date: Sun Mar 22 19:33:10 UTC 2015
New revision: 381949
URL: https://svnweb.freebsd.org/changeset/ports/381949

Log:
  Update to upstream version 0.6.0

  PR:		198439
  Submitted by:	bbtruk@users.sourceforge.net (maintainer)

Changes:
  head/x11-fm/doublecmd/Makefile
  head/x11-fm/doublecmd/distinfo
  head/x11-fm/doublecmd/files/patch-src_platform_uosforms.pas
Comment 11 Thomas Zander freebsd_committer 2015-03-22 19:36:28 UTC
Patch builds indeed fine in quite a few tested OPTIONS permutations. Thanks!