Bug 198903 - [patch] net/libsrtp: update to 1.5.2
Summary: [patch] net/libsrtp: update to 1.5.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tijl Coosemans
URL:
Keywords: patch
: 197073 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-25 18:24 UTC by Tijl Coosemans
Modified: 2015-04-12 12:14 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (alexander)


Attachments
patch (4.44 KB, patch)
2015-03-25 18:24 UTC, Tijl Coosemans
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tijl Coosemans freebsd_committer 2015-03-25 18:24:39 UTC
Created attachment 154801 [details]
patch

- update net/libsrtp to version 1.5.2
- allow the use of base system openssl on FreeBSD 10+
Comment 1 Tijl Coosemans freebsd_committer 2015-03-25 18:26:50 UTC
*** Bug 197073 has been marked as a duplicate of this bug. ***
Comment 2 Guido Falsi freebsd_committer 2015-04-01 15:53:33 UTC
Just some positive feedback:

I'm using this patch in conjunction with the asterisk ports (one of the few consumers of it, which I maintain) and it works quite fine.
Comment 3 commit-hook freebsd_committer 2015-04-12 12:12:05 UTC
A commit references this bug:

Author: tijl
Date: Sun Apr 12 12:12:01 UTC 2015
New revision: 383864
URL: https://svnweb.freebsd.org/changeset/ports/383864

Log:
  Update net/libsrtp to 1.5.2 and use base OpenSSL on FreeBSD 10 and up

  PR:		198903
  Tested by:	madpilot
  Approved by:	maintainer timeout (18 days)

Changes:
  head/net/asterisk/Makefile
  head/net/asterisk11/Makefile
  head/net/asterisk13/Makefile
  head/net/libsrtp/Makefile
  head/net/libsrtp/distinfo
  head/net/libsrtp/files/patch-Makefile.in
  head/net/libsrtp/files/patch-crypto-include-sha1.h
  head/net/libsrtp/files/patch-libsrtp.pc.in
  head/net/libsrtp/pkg-plist
  head/net/ortp/Makefile