Bug 198952 - emulators/virtualbox-ose stopped working (NS_ERROR_FACTORY_NOT_REGISTERED)
Summary: emulators/virtualbox-ose stopped working (NS_ERROR_FACTORY_NOT_REGISTERED)
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-27 18:27 UTC by Jens Grassel
Modified: 2018-01-10 13:12 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Grassel 2015-03-27 18:27:59 UTC
Hi,

the virtualbox port stopped working. If I try to start virtualbox it takes ages (10-15 minutes) until an error popup appears which shows the following message:

Failed to create the VirtualBox COM object.
The application will now terminate.

Callee RC: NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)

# uname -a
FreeBSD thor.rostock.home 10.1-RELEASE-p6 FreeBSD 10.1-RELEASE-p6 #0: Tue Feb 24 19:00:21 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
# pkg info | grep virtualbox-ose
virtualbox-ose-4.3.26          General-purpose full virtualizer for x86 hardware
virtualbox-ose-kmod-4.3.26     VirtualBox kernel module for FreeBSD

I'm not really sure which update did this. Some days ago it was running without problems. But I can reproduce the problem on three machines all on 10.1, same patchlevel, same ports.

Any ideas?

Regards
Comment 1 Neel Chauhan 2015-04-07 18:44:25 UTC
I am having the same problem also.

One short term (but unpleasant) workaround which worked for me is to run "VirtualBox" in a terminal, wait 5-10 seconds, kill VirtualBox with Control-C, wait another 5-10 seconds, and then run "VirtualBox" again in a terminal.
Comment 2 Bernard Spil freebsd_committer 2015-04-08 13:44:54 UTC
Are you running virtualbox from ports or from binary packages?

This is said to be related to the OpenSSL version upgrade to 1.0.2
Comment 3 Bernard Spil freebsd_committer 2015-04-08 14:00:34 UTC
Just downloaded the binary packages from pkg.freebsd.org, these link openssl libs even though the port does not define USE_OPENSSL= yes which is a mistake to begin with...

If you'd have curl built with ports OpenSSL you will have a conflict in the ssl libs.
Comment 4 Jens Grassel 2015-05-12 18:10:26 UTC
Sorry for the late answer, I had a marriage to do. =)

I'm using virtualbox from ports. Today I've had some time to dig into this and I found out that /usr/local/lib/virtualbox/VBoxRT.so was using libcrypto from ports _and_ from base. This seems to indicate that the recent openssl upgrade may indeed be the problem.

I was able to solve this issue by recompiling curl with GSSAPI_NONE.

Regards,

Jens
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-01-10 10:51:23 UTC
Did I understand this right? Is it solved? So it could be closed.
Comment 6 Jens Grassel 2018-01-10 11:12:31 UTC
(In reply to w.schwarzenfeld from comment #5)

Seems so. =)
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-01-10 11:16:48 UTC
So please, close the PR, thanks!