Bug 198984 - [PACTH] misc/linm: Fix iconv/10.1 and LibreSSL build problems
Summary: [PACTH] misc/linm: Fix iconv/10.1 and LibreSSL build problems
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-28 12:14 UTC by Bernard Spil
Modified: 2015-04-11 14:58 UTC (History)
1 user (show)

See Also:


Attachments
svn diff for misc/linm (3.07 KB, patch)
2015-03-28 12:14 UTC, Bernard Spil
no flags Details | Diff
Poudriere build log of misc/linm (119.92 KB, text/plain)
2015-03-28 12:15 UTC, Bernard Spil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2015-03-28 12:14:32 UTC
Created attachment 154915 [details]
svn diff for misc/linm

misc/linm fails to build on 10.1 due to the overlap between base and ports iconv libraries. This implements the standard way to deal with iconv as described in the porter's handbook.

Next to that, linm uses deprecated des methods from des_old.h, this patch replaces them with their replacements enabling building with LibreSSL (OpenSSL head has also removed des_old.h)
Comment 1 Bernard Spil freebsd_committer 2015-03-28 12:15:00 UTC
Created attachment 154916 [details]
Poudriere build log of misc/linm
Comment 2 commit-hook freebsd_committer 2015-04-11 14:56:10 UTC
A commit references this bug:

Author: danfe
Date: Sat Apr 11 14:55:35 UTC 2015
New revision: 383804
URL: https://svnweb.freebsd.org/changeset/ports/383804

Log:
  - Add a patch to replace deprecated des_* methods from des_old.h, which
    enables the build against LibreSSL (OpenSSL head has also removed this
    header)
  - Simplify WRKSRC and move it where it normally belongs in Makefile
  - Remove no longer required "/LIBS=/s|-lpthread|-pthread|" gimmick, and
    bring Makefile header under standard form
  - Provide a better port description while I'm here

  PR:		198984
  Submitted by:	Bernard Spil

Changes:
  head/misc/linm/Makefile
  head/misc/linm/files/patch-panel_common_passencrypt.cpp
  head/misc/linm/pkg-descr
Comment 3 Alexey Dokuchaev freebsd_committer 2015-04-11 14:58:59 UTC
Patch was added (along with few other changes) as of ports r383804.  Note that iconv changes were not committed, as I failed to reproduce the breakage.  Feel free to reopen this bug, but please provide exhaustive analysis and rationale for proposed fix, thank you.