Bug 199113 - japanese/font-ricty: install creates fonts.dir in cwd
Summary: japanese/font-ricty: install creates fonts.dir in cwd
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-02 12:03 UTC by hiroto.kagotani
Modified: 2015-04-07 00:20 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (meta)


Attachments
poudriere build log (30.66 KB, text/plain)
2015-04-02 18:13 UTC, Koichiro Iwao
no flags Details
ja-font-ricty-3.2.4_2 poudriere log (49.43 KB, text/x-log)
2015-04-06 11:00 UTC, hiroto.kagotani
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description hiroto.kagotani 2015-04-02 12:03:40 UTC
When I run make install, it shows an error message at the end:

# make install
===>  Installing for ja-font-ricty-3.2.4_2
===>   ja-font-ricty-3.2.4_2 depends on executable: fc-cache - found
===>   ja-font-ricty-3.2.4_2 depends on file: /usr/local/share/ricty/RictyDiscord-Regular.ttf - found
===>   ja-font-ricty-3.2.4_2 depends on executable: fc-cache - found
===>   ja-font-ricty-3.2.4_2 depends on executable: mkfontdir - found
===>   ja-font-ricty-3.2.4_2 depends on executable: mkfontscale - found
===>  Checking if ja-font-ricty already installed
===>   Registering installation for ja-font-ricty-3.2.4_2
Installing ja-font-ricty-3.2.4_2...
cd: %%X_FONTSDIR%%/TTF: No such file or directory

And "fonts.dir" is created in the current working directory:

# ls -l
total 28
-rw-r--r--  1 root  wheel  3176 Mar 22 08:43 Makefile
-rw-r--r--  1 root  wheel   130 Feb  1 01:48 distinfo
drwxr-xr-x  2 root  wheel   512 Mar 24 15:36 files
-rw-r--r--  1 root  wheel  3878 Apr  2 20:56 fonts.dir
-rw-r--r--  1 root  wheel   135 Jan 23  2014 pkg-descr
-rw-r--r--  1 root  wheel   764 Mar 22 08:43 pkg-plist
drwxr-xr-x  5 root  wheel   512 Apr  2 20:56 work

Since "/usr/local/share/fonts/TTF/fonts.dir" seems to be successfully updated,
"pkg-install.in" may be unnecessary.
Comment 1 Koichiro Iwao freebsd_committer 2015-04-02 18:13:38 UTC
Created attachment 155126 [details]
poudriere build log

Cannot reproduce, successfully builds.
Comment 2 hiroto.kagotani 2015-04-06 11:00:48 UTC
Created attachment 155223 [details]
ja-font-ricty-3.2.4_2 poudriere log

Attached is my poudriere log with updated ports tree.
X_FONTSDIR has been removed at 3.2.4_2.
http://svnweb.freebsd.org/ports/head/japanese/font-ricty/Makefile?r1=381876&r2=381879
Comment 3 commit-hook freebsd_committer 2015-04-06 11:41:27 UTC
A commit references this bug:

Author: bapt
Date: Mon Apr  6 11:40:49 UTC 2015
New revision: 383417
URL: https://svnweb.freebsd.org/changeset/ports/383417

Log:
  Fix post install script

  PR:		199113
  Reported by:	hiroto.kagotani@gmail.com

Changes:
  head/japanese/font-ricty/Makefile
  head/japanese/font-ricty/files/pkg-install.in
Comment 4 Baptiste Daroussin freebsd_committer 2015-04-06 11:43:21 UTC
The issue can only be seen when building bulk -t or testport as it is in the post-install script.

I have missed that one when working on fonts sorry.

This is now fixed. 
I am not even sure that the post-install script is actually needed now, but given I have proper way to check I have left it. The same is present on all Japanese fonts, so I preferred keeping it instead of breaking Japanese fonts, would be nice if some Japanese people could actually check if that is still necessary after my change in fonts handling
Comment 5 Koichiro Iwao freebsd_committer 2015-04-07 00:20:18 UTC
AFAIK, post-install script is written by hrs@.  I just made dead copy of it and made trivial changes thus I'm not familiar with it.

I'm interested in maintaining some Japanese font ports and keep them up-to-date but have no interest in maintaining Japanese font infrastructure.  But I also think Japanese font ports needs to be simplified.