Bug 199120 - multimedia/xmms: cyrillic names/ID3 doesn't show the right characters
Summary: multimedia/xmms: cyrillic names/ID3 doesn't show the right characters
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Christian Weisgerber
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-02 19:48 UTC by w-info
Modified: 2015-04-09 16:21 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description w-info 2015-04-02 19:48:22 UTC
xmms seems now to be built that it displays cyrillic, but it doesn't do it properly... I get junk! Both in the file list from cyrillic file names and in the ID3 information. There seems some bug converting the utf8 to an index into the font(s) used for cyrillic.

I built russian/xmms but that's just a config for xmms and it behaves the same.
Comment 1 w-info 2015-04-02 19:51:27 UTC
Addition/correction: It shows cyrillic characters when they are used in the ID3, but not correct, and for UTF-8 file names from the filing system it shows something else which is junk...
Comment 2 Christian Weisgerber freebsd_committer 2015-04-09 16:21:13 UTC
XMMS can't handle UTF-8 or different character sets, so unless you have ID3 tags in a particular eight-bit encoding (say, KOI8-R) and matching fonts in the same encoding, it won't work.

If you need this capability, you should investigate a more modern audio player such as audio/audacious.

I don't know how you even built russian/xmms since that port has been removed for a year.