Bug 199194 - chinese/ttfm: /usr/local/share/ttfm/xttfm.ttfm still installs symlinks to /usr/local/lib/X11/fonts
Summary: chinese/ttfm: /usr/local/share/ttfm/xttfm.ttfm still installs symlinks to /us...
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Baptiste Daroussin
Depends on:
Reported: 2015-04-06 09:11 UTC by Ting-Wei Lan
Modified: 2020-03-25 16:07 UTC (History)
3 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Ting-Wei Lan 2015-04-06 09:11:22 UTC
After r381876, all fonts ports are modified to install in /usr/local/share/fonts, but the script /usr/local/share/ttfm/xttfm.ttfm included in chinese/ttfm port still adds symlinks to /usr/local/lib/X11/fonts.

Comment 1 Walter Schwarzenfeld freebsd_triage 2018-01-10 09:11:25 UTC
Is overcome by events. Found no  /usr/local/lib/X11/fonts directory on my system.
I think it's could closed.
Comment 2 Ting-Wei Lan 2018-01-10 09:38:47 UTC
(In reply to w.schwarzenfeld from comment #1)
No, the problem is still not resolved. /usr/local/lib/X11/fonts will be created if you install chinese/CJKUnifonts or chinese/arphicttf.
Comment 3 Baptiste Daroussin freebsd_committer 2020-03-24 16:28:56 UTC
I just tried (sorry again for the delay) and I can't reproduce, I will close it for now, if you find a way to reproduce, please reopen.
Comment 4 Ting-Wei Lan 2020-03-25 16:07:31 UTC
I can reproduce the issue by building chinese/arphicttf with X11 option enabled.