Bug 199341 - mail/mutt: crash after exiting pgp key selection
Summary: mail/mutt: crash after exiting pgp key selection
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on: 199727
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-10 08:57 UTC by rsos+freebsd
Modified: 2015-05-18 18:20 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (Udo.Schweigert)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rsos+freebsd 2015-04-10 08:57:19 UTC
Hello!

I'm using mutt and added to the addresses with an available GPG key a send-hook to automatically encrypt the sended messages.

Currently I wrote an email to several recipients. From one person I have a GPG key. So mutt wanted to encrypt the message and when sending the message I got an field to enter the GPG key id for the person I have no key. I pressed enter and got to the selection list with all available keys.

Then -- as I had no key -- I pressed "q" to exit the selection list. After pressing "q" mutt crashed with following message:
sh: bus error (core) dumped mutt

Debugging with gdb I got the following backtrace:
(gdb) bt
#0  0x0000000801ecff8b in ?? ()
#1  0x00007fffffffb100 in ?? ()
#2  0x0000000800913054 in ?? ()
#3  0x8ecd5f55e3fb9844 in ?? ()
#4  0x0000000000000000 in ?? ()

(I have no debug symbols installed but I think the bug is easily reproducable.)

Thanks for your help!
Comment 1 Udo.Schweigert 2015-04-10 09:34:09 UTC
Please report this bug upstream, I only maintain the port - not the software itself...

@Committer: please close this PR as it is not related to the port itself.
Comment 2 commit-hook freebsd_committer 2015-05-16 01:20:12 UTC
A commit references this bug:

Author: jbeich
Date: Sat May 16 01:19:13 UTC 2015
New revision: 386495
URL: https://svnweb.freebsd.org/changeset/ports/386495

Log:
  mail/mutt: update patches

  - Fix sidebar patch [1]. This version introduces a new config variable
    "sidebar_shortpath" which is set to yes by default to ensure
    backwards compatibility.

  - Fix an issue with recent gpg (and gpgme) versions (GnuPG version 2.1
    stops exporting the GPG_AGENT_INFO environment variable, so mutt can't
    check for the presence of that to ensure the agent is running).

  - Fix pgp key selection [2].

  - Bump port revision because of major change to sidebar patch and gpg
    handling.

  PR:		199727
  PR:		199115 [1]
  PR:		199341 [2]
  Submitted by:	Udo.Schweigert@siemens.com (maintainer)
  MFH:		2015Q2

Changes:
  head/chinese/mutt/Makefile
  head/mail/mutt/Makefile
  head/mail/mutt/files/extra-patch-sidebar
  head/mail/mutt/files/extra-patch-sidebar-nntp
  head/mail/mutt/files/extra-patch-sidebar-refresh
  head/mail/mutt/files/patch-gpg_agent_info
  head/mail/mutt/files/patch-pgpkey.c
Comment 3 commit-hook freebsd_committer 2015-05-18 18:20:30 UTC
A commit references this bug:

Author: jbeich
Date: Mon May 18 18:20:24 UTC 2015
New revision: 386696
URL: https://svnweb.freebsd.org/changeset/ports/386696

Log:
  MFH: r386495

  mail/mutt: update patches

  - Fix sidebar patch [1]. This version introduces a new config variable
    "sidebar_shortpath" which is set to yes by default to ensure
    backwards compatibility.

  - Fix an issue with recent gpg (and gpgme) versions (GnuPG version 2.1
    stops exporting the GPG_AGENT_INFO environment variable, so mutt can't
    check for the presence of that to ensure the agent is running).

  - Fix pgp key selection [2].

  - Bump port revision because of major change to sidebar patch and gpg
    handling.

  PR:		199727
  PR:		199115 [1]
  PR:		199341 [2]
  Submitted by:	Udo.Schweigert@siemens.com (maintainer)
  Approved by:	ports-secteam (delphij)

Changes:
_U  branches/2015Q2/
  branches/2015Q2/chinese/mutt/Makefile
  branches/2015Q2/mail/mutt/Makefile
  branches/2015Q2/mail/mutt/files/extra-patch-sidebar
  branches/2015Q2/mail/mutt/files/extra-patch-sidebar-nntp
  branches/2015Q2/mail/mutt/files/extra-patch-sidebar-refresh
  branches/2015Q2/mail/mutt/files/patch-gpg_agent_info
  branches/2015Q2/mail/mutt/files/patch-pgpkey.c