Bug 199386 - multimedia/livestreamer slow start up mplayer/mplayer2 on some streaming video.
Summary: multimedia/livestreamer slow start up mplayer/mplayer2 on some streaming video.
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Only Me
Assignee: freebsd-multimedia (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-12 05:56 UTC by sasamotikomi
Modified: 2017-10-08 10:42 UTC (History)
4 users (show)

See Also:
riggs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasamotikomi 2015-04-12 05:56:42 UTC
Mplayer took 20s. up to 5 min. to start some video stream while vlc started same stream immediately, mplayer2 can't start some stream even after 5 minutes.
VLC and Mplayer/Mplayer2 from official FreeBSD pkg repo.
Comment 1 sasamotikomi 2015-04-12 06:24:03 UTC
(In reply to sasamotikomi from comment #0)
I tried use difference size of -cache or -n, nothing changed but I think problem reproduced only with https:// stream, http:// start fine.
Comment 2 sasamotikomi 2015-04-12 07:09:36 UTC
(In reply to sasamotikomi from comment #1)
Problem not with https:// only 50~60 https vs 30~40 http.
Comment 3 Thomas Zander freebsd_committer 2015-04-12 11:28:29 UTC
Again, please provide a concrete example (e.g. complete command line that we can use for testing). If you want someone to fix those problems, you have make it easy to reproduce.
Comment 4 Juergen Lock freebsd_committer 2015-04-12 11:41:21 UTC
Hmm.  I'm inclined to think this issue is with mplayer/mplayer2 since livestreamer just passes the stream to the player on stdin...

I tested:

livestreamer http://www.ustream.tv/channel/nasa-hd-tv worst -p mplayer

and indeed mplayer took > 10s to startup, mplayer2 didn't even start at all ("[cli][info] Player closed"), while -p mpv or -p ffplay like the default of vlc started immediately.

And now I tried mplayer2 with -v and got:

% livestreamer http://www.ustream.tv/channel/nasa-hd-tv worst -v -p mplayer
[cli][info] Found matching plugin ustreamtv for URL http://www.ustream.tv/channel/nasa-hd-tv
[cli][info] Available streams: 240p, 240p_alt_akamai, 720p+ (best), 720p+_alt_akamai, mobile_240p (worst)
[cli][info] Opening stream: mobile_240p (hls)
[cli][info] Starting player: mplayer
MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
Cannot open file '/home/nox/.mplayer/input.conf': No such file or directory
Failed to open /home/nox/.mplayer/input.conf.
Cannot open file '/usr/local/etc/mplayer/input.conf': No such file or directory
Failed to open /usr/local/etc/mplayer/input.conf.

Playing -.
Reading from stdin...
Detected file format: MPEG-TS (MPEG-2 Transport Stream) (libavformat)
Assertion v>0 && v<=(1 ? 32 : 16) failed at libavutil/mem.c:226


MPlayer interrupted by signal 6 in module: demux_open
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
[cli][info] Player closed
[cli][info] Stream ended
% 

..so it clearly looks like mplayer2 not liking that particular stream.
Comment 5 Juergen Lock freebsd_committer 2015-04-12 11:49:42 UTC
..and mplayer with the same stream and -v got:

% livestreamer http://www.ustream.tv/channel/nasa-hd-tv worst -v -p mplayer                      
[cli][info] Found matching plugin ustreamtv for URL http://www.ustream.tv/channel/nasa-hd-tv
[cli][info] Available streams: 240p, 240p_alt_akamai, 720p+ (best), 720p+_alt_akamai, mobile_240p (worst)
[cli][info] Opening stream: mobile_240p (hls)
[cli][info] Starting player: mplayer
MPlayer SVN-r37386-snapshot-3.4.1 (C) 2000-2015 MPlayer Team

Playing -.
Reading from stdin...
libavformat version 56.28.100 (internal)
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
TS file format detected.
Cannot seek backward in linear streams!
Seek failed
VIDEO H264(pid=256) AUDIO AAC(pid=257) NO SUBS (yet)!  PROGRAM N. 1
Cannot seek backward in linear streams!
Seek failed
FPS seems to be: 30.000000
Load subtitles in ./
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 56.33.100 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, floatle, 0.0 kbit/0.00% (ratio: 0->352800)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.77:1 - prescaling to correct movie aspect.
[..]

so it clearly looks like the issue is with the players not livestreamer itself.
Comment 6 Anonymous 2015-04-17 00:16:05 UTC
Could you test if mpv has the same issues or fixes your problem? Not really a fix but we can then guarantee x the player is at fault.
Comment 7 sasamotikomi 2015-04-21 12:21:35 UTC
(In reply to chris from comment #6)
Sorry, I can't use mpv because it has some issue with i386:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=198758
Comment 8 Thomas Zander freebsd_committer 2015-06-14 11:21:16 UTC
(In reply to sasamotikomi from comment #7)

You could build one yourself from ports without OPENCV.
Comment 9 Thomas Zander freebsd_committer 2015-09-13 09:30:45 UTC
(In reply to sasamotikomi from comment #7)

The mpv issue should be resolved by now.
Could you check if this is still reproducible?
Comment 10 sasamotikomi 2015-09-16 00:02:49 UTC
(In reply to Thomas Zander from comment #9)
Mpv and mplayer2 now work fine for me but mplayer still isn't.
Comment 11 Thomas Zander freebsd_committer 2017-05-20 17:35:31 UTC
(In reply to sasamotikomi from comment #10)

If this problem still persists, could you take it upstream?