Bug 200368 - [vmware] FreeBSD terminal stops responding to input
Summary: [vmware] FreeBSD terminal stops responding to input
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.1-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-virtualization mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-21 14:34 UTC by Phillip
Modified: 2017-05-31 17:53 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phillip 2015-05-21 14:34:08 UTC
Active FreeBSD terminal stops responding if using it in vmware workstation while connected to the host machine over remote desktop connection. Issue is intermittent and only occurs occasionally, however the issue is rather easy to reproduce.

Info:

host:
vmware workstation 11.0 - .1 (upgraded to resolve issue, failed)
4 core intel xeon CPU
16 gb ram

VM:

1 core
128 mb ram (tried raising amount to 2 gb, no effect. top shows nominal memory usage)


Steps to reproduce:

Scenario: connect to a remote windows 2012 server running vmware workstation 11.1 with a freebsd VM.

while logged in (has occurred at log in terminal as well) press ctl + alt to release control from the VM and minimize the remote desktop connection session. Proceed to use other windows on the connected remote client computer that is connected to the server remotely. after maximizing the RDP session again attempt to click on the VM window to direct input into the FreeBSD virtual machine. The terminal should lock up and no longer respond to commands. It make take a few tries as this is a random occurrence. If I could give it a occurrence probability it would occur 3/10 of the times i tried to replicate it.

Expected Result: clicking back into the FreeBSD VM should of directed input to the vm and allowed the user to continue whatever they were doing and continue to provide screen refreshes.

Actual Result: System becomes unresponsive and does NOT refresh the ACTIVE terminal. I found pressing CTL + ALT + F1-7 allowed me to log into another terminal and log in to continue working.

Please let me know if you require more details and I do apologize if I missed something.