Bug 201147 - ftp/curl: Fix bug in multi handles
Summary: ftp/curl: Fix bug in multi handles
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Po-Chuan Hsieh
URL:
Keywords:
: 201145 201146 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-27 10:09 UTC by Michael Gmelin
Modified: 2015-06-28 18:12 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Gmelin freebsd_committer 2015-06-27 10:09:44 UTC
Curl 7.43.0 introduced a bug that causes invalid behavior when using multi handles. Among other things this broke arcanist (which makes use of multi handles).

See:
https://reviews.freebsd.org/D2894
https://secure.phabricator.com/T8654
http://curl.haxx.se/mail/lib-2015-06/0127.html
http://curl.haxx.se/mail/lib-2015-06/0131.html

The attached patch incorporates https://github.com/bagder/curl/commit/903b6e05565bf826b4194447864288642214b094 (https://github.com/bagder/curl/commit/903b6e05565bf826b4194447864288642214b094.diff for the raw diff) form upstream, that aims to fix this problem.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2015-06-27 23:28:01 UTC
*** Bug 201146 has been marked as a duplicate of this bug. ***
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2015-06-27 23:28:15 UTC
*** Bug 201145 has been marked as a duplicate of this bug. ***
Comment 3 commit-hook freebsd_committer 2015-06-28 17:54:42 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Jun 28 17:53:56 UTC 2015
New revision: 390806
URL: https://svnweb.freebsd.org/changeset/ports/390806

Log:
  - Fix multi handles
  - Bump PORTREVISION for package change

  PR:		201147
  Submitted by:	grembo
  Obtained from:	https://github.com/bagder/curl/commit/903b6e05565bf826b4194447864288642214b094

Changes:
  head/ftp/curl/Makefile
  head/ftp/curl/files/patch-lib-multi.c
  head/ftp/curl/files/patch-lib-transfer.c
Comment 4 Po-Chuan Hsieh freebsd_committer 2015-06-28 18:12:03 UTC
Committed. Thanks!