Bug 201437 - www/seahub: Reinstall or upgrade overwrites settings.py
Summary: www/seahub: Reinstall or upgrade overwrites settings.py
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Martin Wilke
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2015-07-09 11:13 UTC by Christoph H. Larsen
Modified: 2016-06-07 02:04 UTC (History)
5 users (show)

See Also:
vlad-fbsd: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph H. Larsen 2015-07-09 11:13:22 UTC
Dear Jingfeng,
It seems that reinstallation or upgrading of this port overwrites settings.py in haiwen/seafile-server/seahub/seahub/.
I suppose that this s not desired behaviour.


Also, the seahub bash scripts continue contain placeholders that should be replaced with the correct installation directories.
Kindly see below:

--> /usr/local/www/haiwen/seafile-server/seahub/send_user_notifications.sh:

#cd ##FIX_WWWDIR##/seafile-server/seahub
cd /usr/local/www/haiwen/seafile-server/seahub

#export CCNET_CONF_DIR=##FIX_WWWDIR##/ccnet
export CCNET_CONF_DIR=/usr/local/www/haiwen/ccnet

#export SEAFILE_CONF_DIR=##FIX_WWWDIR##/seafile-data
export SEAFILE_CONF_DIR=/home/[instance]/data


--> /usr/local/www/haiwen/seafile-server/seahub/setenv.sh:

#export CCNET_CONF_DIR=##FIX_WWWDIR##/ccnet
export CCNET_CONF_DIR=/usr/local/www/haiwen/ccnet

#export SEAFILE_CONF_DIR=##FIX_WWWDIR##/seafile-data
export SEAFILE_CONF_DIR=/home/[instance]/data

What do you think?

Thank a lot, indeed.

Chris
Comment 1 Carlo Strub freebsd_committer 2015-09-15 22:31:52 UTC
Could you please provide a patch.
Comment 2 Ultima 2015-10-21 15:37:32 UTC
 Settings.py is not a configuration file, it is changed on every update. The configuration file for settings.py is seahub_settings.py in the haiwen directory.

bug 203929 is an port update that contains many fixes including the #FIX_WWWDIR placeholder.

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203929
Comment 3 Ultima 2016-06-06 23:50:16 UTC
This is not a bug and works as intended, the configuration file for settings.py is /usr/local/www/haiwen/conf/seahub_settings.py. Anything you need to edit in settings.py should be placed in this file as it is not overwritten.

This bug should be safe to close.
Comment 4 VK freebsd_triage 2016-06-07 01:16:54 UTC
Maintainer feedback timeout. I guess this is up to you now, Martin.
Comment 5 VK freebsd_triage 2016-06-07 02:04:07 UTC
Ah, the maintainers changed, per Bug #204110, which occurred many moons ago, so I'm actually setting this to maintainer-feedback+ because Ultima responded.

Also, closing.