Bug 201521 - [NEW PORT] net/librdkafka
Summary: [NEW PORT] net/librdkafka
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-13 10:58 UTC by Victor Yagofarov
Modified: 2015-08-02 19:01 UTC (History)
3 users (show)

See Also:


Attachments
A C library implementation of the Apache Kafka protocol (343 bytes, application/x-shar)
2015-07-13 10:58 UTC, Victor Yagofarov
no flags Details
fixed librdkafka.shar (2.96 KB, application/x-shar)
2015-07-13 17:17 UTC, Victor Yagofarov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Yagofarov 2015-07-13 10:58:54 UTC
Created attachment 158684 [details]
A C library implementation  of the Apache Kafka protocol

C library implementation 
of the Apache Kafka protocol, containing both Producer and 
Consumer support.

WWW: https://github.com/edenhill/librdkafka/
Comment 1 Vanilla I. Shu freebsd_committer 2015-07-13 14:11:52 UTC
The shar file seems broken, please resend another one, thanks.
Comment 2 Victor Yagofarov 2015-07-13 17:17:27 UTC
Created attachment 158703 [details]
fixed librdkafka.shar

fixed shar
Comment 3 Kurt Jaeger freebsd_committer 2015-07-17 15:51:11 UTC
testing@work
Comment 4 Kurt Jaeger freebsd_committer 2015-07-17 16:55:44 UTC
It builds on 10.1a and 9.3a.

It fails to build on i386, due to:

snappy.c:133:19: error: unused function 'find_lsb_set_non_zero64' [-Werror,-Wunused-function]

Using

GH_TAGNAME=     e3d98484a

fixes this and the patch-configure is also no longer needed.

If the submitter approves, I can commit this.
Comment 5 commit-hook freebsd_committer 2015-07-24 11:14:48 UTC
A commit references this bug:

Author: pi
Date: Fri Jul 24 11:14:43 UTC 2015
New revision: 392820
URL: https://svnweb.freebsd.org/changeset/ports/392820

Log:
  New port: net/librdkafka

  This is a port of librdkafka, a C library implementation
  of the Apache Kafka protocol, containing both Producer and
  Consumer support. It was designed with message delivery
  reliability and high performance in mind, current figures
  exceed 800000 msgs/second for the producer and 3 million
  msgs/second for the consumer.

  WWW: https://github.com/edenhill/librdkafka/

  PR:		201521
  Submitted by:	Victor Yagofarov <xnasx@yandex.ru>

Changes:
  head/net/Makefile
  head/net/librdkafka/
  head/net/librdkafka/Makefile
  head/net/librdkafka/distinfo
  head/net/librdkafka/pkg-descr
  head/net/librdkafka/pkg-plist
Comment 6 Kurt Jaeger freebsd_committer 2015-07-24 11:16:57 UTC
Submitter feedback received, committed, thank you very much!
Comment 7 Victor Yagofarov 2015-07-27 11:12:43 UTC
Build failed on freebsd.org's poudriere at Configure phase:
http://beefy1.nyi.freebsd.org/data/93i386-default/392908/logs/librdkafka-0.8.6.log

"checking for __atomic_32 (by compile)... failed"
and other errors about "*atomic*"

But it's ok on my company poudriere and two my PC's.

Any idias how to fix it?
Comment 8 Kurt Jaeger freebsd_committer 2015-08-02 17:30:16 UTC
I also have this build failure on 9.3i with poudriere.

No idea for a fix right now.
Comment 9 Victor Yagofarov 2015-08-02 18:08:48 UTC
The solution is adding "-march=pentium" into compiler flags.
But it is hard for me to write a patch for this configure scripts.
Comment 10 commit-hook freebsd_committer 2015-08-02 18:59:51 UTC
A commit references this bug:

Author: pi
Date: Sun Aug  2 18:59:02 UTC 2015
New revision: 393439
URL: https://svnweb.freebsd.org/changeset/ports/393439

Log:
  net/librdkafka: fix build on 9.3-i386

  - Adding -march=pentium to CFLAGS on this arch

  PR:		201521
  Submitted by:	Victor Yagofarov <xnasx@yandex.ru> (maintainer)

Changes:
  head/net/librdkafka/Makefile
Comment 11 Kurt Jaeger freebsd_committer 2015-08-02 19:01:03 UTC
Thanks for the hint, this allowed me to put a fix in the Makefile.