Bug 202174 - www/firefox: firefox 40 crashes after a few minutes of usage
Summary: www/firefox: firefox 40 crashes after a few minutes of usage
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
: 202184 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-08 10:16 UTC by Martin Birgmeier
Modified: 2016-09-11 23:59 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments
gdb session on firefox.core (24.98 KB, text/plain)
2015-08-08 10:16 UTC, Martin Birgmeier
no flags Details
gdb session for next crash (26.50 KB, text/plain)
2015-08-08 10:48 UTC, Martin Birgmeier
no flags Details
firefox gdb two core (48.77 KB, text/plain)
2015-08-08 12:19 UTC, Andrey Fesenko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2015-08-08 10:16:09 UTC
Created attachment 159659 [details]
gdb session on firefox.core

I just built and installed firefox-40.0,1. Now firefox crashes everytime after a few minutes of activity.

Attached is a short gdb session on firefox.core.
Comment 1 Jan Beich freebsd_committer 2015-08-08 10:27:24 UTC
Can you try the suggestion in bug 202165 comment 5 ? Restart firefox and check "GPU Accelerated Windows" in about:support which should no longer have "(OMTC)".
Comment 2 Martin Birgmeier 2015-08-08 10:48:57 UTC
Created attachment 159660 [details]
gdb session for next crash
Comment 3 Andrey Fesenko 2015-08-08 12:17:56 UTC
confirm, random crashes, core files not identical
Comment 4 Andrey Fesenko 2015-08-08 12:19:05 UTC
Created attachment 159663 [details]
firefox gdb two core
Comment 5 Martin Birgmeier 2015-08-08 12:47:18 UTC
(In reply to Jan Beich from comment #1)

I changed the setting and verified that "OMTC" is no longer shown (it indeed was before).

I have not had a crash so far; of course, I'll have to test somewhat longer...

Also:
- I do have an nvidia card and use the (closed-source) nvidia driver
- I did indeed have the impression that firefox was crashing while scrolling (using the mouse wheel)

So, let's keep fingers crossed. I'll keep you posted.
Comment 6 Andrey Fesenko 2015-08-08 14:05:24 UTC
(In reply to Jan Beich from comment #1)
"about:config:

  layers.offmainthreadcomposition.enabled -> false"
work fine for me, video i5-intel Sandybridge Mobile, ff build with:
OPTIONS_FILE_SET+=GTK2
OPTIONS_FILE_UNSET+=GTK3
Comment 7 Kurt Jaeger freebsd_committer 2015-08-09 16:24:41 UTC
*** Bug 202184 has been marked as a duplicate of this bug. ***
Comment 8 commit-hook freebsd_committer 2015-08-09 16:31:31 UTC
A commit references this bug:

Author: jbeich
Date: Sun Aug  9 16:30:46 UTC 2015
New revision: 393804
URL: https://svnweb.freebsd.org/changeset/ports/393804

Log:
  www/firefox: make testing bundled cairo easier via option

  BUNDLED_CAIRO does nothing with GTK3 until Firefox 41.0
  https://bugzilla.mozilla.org/show_bug.cgi?id=1159273

  PR:		202174
  MFH:		2015Q3

Changes:
  head/Mk/bsd.gecko.mk
  head/mail/thunderbird/Makefile
  head/www/firefox/Makefile
  head/www/firefox/Makefile.options
  head/www/firefox-esr/Makefile
  head/www/libxul/Makefile
  head/www/seamonkey/Makefile
Comment 9 commit-hook freebsd_committer 2015-08-09 16:31:33 UTC
A commit references this bug:

Author: jbeich
Date: Sun Aug  9 16:31:02 UTC 2015
New revision: 393805
URL: https://svnweb.freebsd.org/changeset/ports/393805

Log:
  www/firefox: temporarily disable OMTC to avoid crashes

  OMTC on X11 platforms uses BasicCompositor unless GL layers are
  also enabled. Change the default value of its pref in about:config.
  For now, bundled cairo is left as is pending more testing.

  No upstream bug as I cannot reproduce reliably to get the stacktrace(s)
  with a clean profile.

  PR:		202174
  Reported by:	many
  Tested by:	Martin Birgmeier, Andrey Fesenko, Konstantin Belousov
  MFH:		2015Q3
  X-MFH-With:	r393690

Changes:
  head/www/firefox/Makefile
  head/www/firefox/files/patch-modules-libpref-init-all.js
Comment 10 Jan Beich freebsd_committer 2015-08-09 16:40:53 UTC
Thanks. Worked around. Test BUNDLED_CAIRO if you really want OMTC benefits.
Comment 11 commit-hook freebsd_committer 2015-08-11 08:14:05 UTC
A commit references this bug:

Author: jbeich
Date: Tue Aug 11 08:13:26 UTC 2015
New revision: 393934
URL: https://svnweb.freebsd.org/changeset/ports/393934

Log:
  MFH: r393804

  www/firefox: make testing bundled cairo easier via option

  BUNDLED_CAIRO does nothing with GTK3 until Firefox 41.0
  https://bugzilla.mozilla.org/show_bug.cgi?id=1159273

  PR:		202174
  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2015Q3/
  branches/2015Q3/Mk/bsd.gecko.mk
  branches/2015Q3/mail/thunderbird/Makefile
  branches/2015Q3/www/firefox/Makefile
  branches/2015Q3/www/firefox/Makefile.options
  branches/2015Q3/www/firefox-esr/Makefile
  branches/2015Q3/www/libxul/Makefile
  branches/2015Q3/www/seamonkey/Makefile
Comment 12 commit-hook freebsd_committer 2015-08-11 18:30:55 UTC
A commit references this bug:

Author: jbeich
Date: Tue Aug 11 18:30:04 UTC 2015
New revision: 393958
URL: https://svnweb.freebsd.org/changeset/ports/393958

Log:
  MFH: r393690, r393803, r393805, r393879

  - Update Firefox to 40.0
  - Update Firefox ESR and libxul to 38.2.0
  - Phase out no longer supported LOGGING option [1]
  - Temporarily disable OMTC to avoid crashes [2]

  PORTREVISION was MFH'd as is to avoid merge conflicts in future.

  Changes:	https://www.mozilla.org/firefox/40.0/releasenotes/
  Changes:	https://www.mozilla.org/firefox/38.2.0/releasenotes/
  PR:		202165 [1]
  PR:		202174 [2]
  Reported by:	rsmith@xs4all.nl [1]
  Reported by:	many [2]
  Tested by:	Martin Birgmeier, Andrey Fesenko, Konstantin Belousov [2]
  Approved by:	ports-secteam (delphij, feld)

Changes:
_U  branches/2015Q3/
  branches/2015Q3/Mk/Uses/gecko.mk
  branches/2015Q3/Mk/bsd.gecko.mk
  branches/2015Q3/www/firefox/Makefile
  branches/2015Q3/www/firefox/distinfo
  branches/2015Q3/www/firefox/files/patch-bug1021761
  branches/2015Q3/www/firefox/files/patch-bug1073117
  branches/2015Q3/www/firefox/files/patch-bug826985
  branches/2015Q3/www/firefox/files/patch-bug847568
  branches/2015Q3/www/firefox/files/patch-ijg-libjpeg
  branches/2015Q3/www/firefox/files/patch-modules-libpref-init-all.js
  branches/2015Q3/www/firefox/files/patch-system-openh264
  branches/2015Q3/www/firefox/files/patch-z-bug517422
  branches/2015Q3/www/firefox-esr/Makefile
  branches/2015Q3/www/firefox-esr/distinfo
  branches/2015Q3/www/firefox-esr-i18n/Makefile
  branches/2015Q3/www/firefox-esr-i18n/distinfo
  branches/2015Q3/www/firefox-i18n/Makefile
  branches/2015Q3/www/firefox-i18n/distinfo
  branches/2015Q3/www/libxul/Makefile
  branches/2015Q3/www/libxul/distinfo
  branches/2015Q3/www/linux-firefox/Makefile
  branches/2015Q3/www/linux-firefox/distinfo
  branches/2015Q3/www/linux-firefox/pkg-plist
Comment 13 commit-hook freebsd_committer 2016-01-08 04:18:50 UTC
A commit references this bug:

Author: jbeich
Date: Fri Jan  8 04:17:48 UTC 2016
New revision: 405511
URL: https://svnweb.freebsd.org/changeset/ports/405511

Log:
  www/firefox: enable BUNDLED_CAIRO per r393805

  Electrolysis is going to require OMTC which had stability issues with
  system Cairo. To avoid trainwreck let's get more exposure.

  https://wiki.mozilla.org/Electrolysis#Schedule

  PR:		202174 (ping)

Changes:
  head/www/firefox/Makefile
Comment 14 commit-hook freebsd_committer 2016-09-08 06:50:11 UTC
A commit references this bug:

Author: jbeich
Date: Thu Sep  8 06:49:11 UTC 2016
New revision: 421532
URL: https://svnweb.freebsd.org/changeset/ports/421532

Log:
  www/firefox: re-enable OMTC for BUNDLED_CAIRO=off (backing out r393805)

  OMTC is also required to support Electrolysis (called Multiprocess Windows in
  about:support) introduced in Firefox 48 via e10srollout@mozilla.org system addon.

  PR:		202174, 211792
  Tested by:	scf
  MFH:		2016Q3

Changes:
  head/www/firefox/Makefile
  head/www/firefox/files/patch-modules-libpref-init-all.js
Comment 15 commit-hook freebsd_committer 2016-09-11 23:59:46 UTC
A commit references this bug:

Author: jbeich
Date: Sun Sep 11 23:58:51 UTC 2016
New revision: 421886
URL: https://svnweb.freebsd.org/changeset/ports/421886

Log:
  MFH: r421532

  www/firefox: re-enable OMTC for BUNDLED_CAIRO=off (backing out r393805)

  OMTC is also required to support Electrolysis (called Multiprocess Windows in
  about:support) introduced in Firefox 48 via e10srollout@mozilla.org system addon.

  PR:		202174, 211792
  Tested by:	scf
  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2016Q3/
  branches/2016Q3/www/firefox/Makefile
  branches/2016Q3/www/firefox/files/patch-modules-libpref-init-all.js