Bug 202250 - graphics/rawtherapee: abort()s on startup
Summary: graphics/rawtherapee: abort()s on startup
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthias Andree
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-11 19:32 UTC by Christoph Moench-Tegeder
Modified: 2016-11-15 09:24 UTC (History)
1 user (show)

See Also:
mandree: maintainer-feedback+


Attachments
catch glib exception when creating directory monitors (1002 bytes, text/x-c++src)
2015-08-11 19:32 UTC, Christoph Moench-Tegeder
no flags Details
logfile from poudriere testport, 10.1-amd64 (728.58 KB, text/plain)
2015-08-11 19:36 UTC, Christoph Moench-Tegeder
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Moench-Tegeder freebsd_committer 2015-08-11 19:32:56 UTC
Created attachment 159777 [details]
catch glib exception when creating directory monitors

Since the latest devel/glib20 change, rawtherapee coredumps on abort() when starting in directory browser mode (opening single files via command line still works).
Backtraces and debugging show that the abort() is caused by an uncaught exception from glibmm, which in turn is a translation of an error returnen from glib. The text of the original error message is "Unable to find default local directory monitor".
The file monitoring code has been disabled in https://svnweb.freebsd.org/ports?view=revision&sortby=date&revision=393663 so this issue here is related to 202128.
As the file/directory monitoring code has been reported as "broken" I did not check if reverting r393663 fixes this.

Instead the attached patch catches the exception and logs an error. This way, the main directory browser functionality has been restored for me.
Comment 1 Christoph Moench-Tegeder freebsd_committer 2015-08-11 19:34:48 UTC
Comment on attachment 159777 [details]
catch glib exception when creating directory monitors

This file should be droppen in graphics/rawtherapee/files/.
PKGVERSION should be bumped to force the re-compile.
Comment 2 Christoph Moench-Tegeder freebsd_committer 2015-08-11 19:36:44 UTC
Created attachment 159778 [details]
logfile from poudriere testport, 10.1-amd64
Comment 3 vermaden 2015-08-23 01:07:20 UTC
Any estimate when this will be fixed?

Thanks,
vermaden
Comment 4 Matthias Andree freebsd_committer 2015-08-23 10:22:53 UTC
(In reply to vermaden from comment #3)
Give me a few days for getting things reproduced and tested.
Comment 5 commit-hook freebsd_committer 2015-08-23 13:52:42 UTC
A commit references this bug:

Author: mandree
Date: Sun Aug 23 13:52:28 UTC 2015
New revision: 395090
URL: https://svnweb.freebsd.org/changeset/ports/395090

Log:
  Fix devel/glib20-induced abort() with dir monitoring.

  Note: untested in poudriere since texlive-base is currently defunct.

  I could reproduce the problem on 10.1-amd64 on a bare metal build
  and check that Christoph's patch works, so committing it. Please report
  fall-out in the PR indicated below.

  + Bump PORTREVISION to trigger rebuild.

  PR:		202250
  Submitted by:	Christoph Moench-Tegeder

Changes:
  head/graphics/rawtherapee/Makefile
  head/graphics/rawtherapee/files/patch-202250
Comment 6 Matthias Andree freebsd_committer 2015-08-23 13:53:41 UTC
I can't test anything but 10.1-amd64 right now, where it works for me. Committing anyways since the patch looks safe on other systems.
Comment 7 Matthias Andree freebsd_committer 2015-08-23 13:54:50 UTC
Fixed - thanks, Christoph!

(currently depends on texlive-base fallout from r395047 to be fixed by hrs@)
Comment 8 Matthias Andree freebsd_committer 2015-08-23 13:55:29 UTC
Fix is in PORTREVISION 3. (4.2_3)
Comment 9 vermaden 2015-08-24 07:48:50 UTC
Confirmed, works properly, thanks for fast fix!

Regards,
vermaden