Bug 202457 - graphics/darktable: bus error (core dumped) /usr/local/bin/darktable
Summary: graphics/darktable: bus error (core dumped) /usr/local/bin/darktable
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Only Me
Assignee: Jean-Sébastien Pédron
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-19 10:32 UTC by Ludger Bolmerg
Modified: 2016-02-13 14:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludger Bolmerg 2015-08-19 10:32:43 UTC
bus error (core dumped)  /usr/local/bin/darktable when toggling the over/underexposed indication button

FreeBSD ludger-thinkpad.fritz.box 10.2-STABLE FreeBSD 10.2-STABLE #0 r286786: Fri Aug 14 22:33:06 CEST 2015     ludger@ludger-thinkpad.fritz.box:/usr/obj/usr/src/sys/GENERIC  i386

...
(gdb) bt
#0  0x2c656c16 in process ()
   from /usr/local/lib/darktable/plugins/liboverexposed.so
#1  0x28165183 in dt_dev_pixelpipe_flush_caches ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#2  0x28164375 in dt_dev_pixelpipe_flush_caches ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#3  0x28164375 in dt_dev_pixelpipe_flush_caches ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#4  0x28164375 in dt_dev_pixelpipe_flush_caches ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#5  0x281645b2 in dt_dev_pixelpipe_flush_caches ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#6  0x28163e53 in dt_dev_pixelpipe_process ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#7  0x281504b4 in dt_dev_process_image_job ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#8  0x2814e714 in dt_dev_process_image_job_create ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#9  0x28148e73 in dt_control_jobs_init ()
   from /usr/local/bin/../lib/darktable/libdarktable.so
#10 0x29260bfc in pthread_create () from /lib/libthr.so.3
#11 0x00000000 in ?? ()
Comment 1 Jean-Sébastien Pédron freebsd_committer 2015-08-26 17:08:46 UTC
Hello!

I couldn't reproduce this problem here. I suppose this is related to a 32bit build of darktable.

Could you please try to build darktable with the debugging symbols (make WITH_DEBUG=1 && make WITH_DEBUG=1 deinstall install), then run darktable from gdb791 (gdb791 /usr/local/bin/darktable)?
Comment 2 Ludger Bolmerg 2015-08-26 20:28:38 UTC
gdb791 /usr/local/bin/darktable
GNU gdb (GDB) 7.9.1 [GDB v7.9.1 for FreeBSD]
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-portbld-freebsd10.1".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/local/bin/darktable...done.
(gdb) r
Starting program: /usr/local/bin/darktable 
[New Thread 2c803080 (LWP 100262)]
[New Thread 2c804980 (LWP 100649)]
[New Thread 2c804480 (LWP 100646)]
[New Thread 2c804c00 (LWP 100648)]
[New Thread 2c804700 (LWP 100647)]
[New Thread 2c804200 (LWP 100645)]
[New Thread 2c803f80 (LWP 100644)]

Program received signal SIGBUS, Bus error.
[Switching to Thread 2c804480 (LWP 100646)]
0x3fa33c1a in process (self=0x2cfbd100, piece=<optimized out>, 
    ivoid=<optimized out>, ovoid=<optimized out>, roi_in=0xbb9fb3e0, 
    roi_out=0xbb9fb620)
    at /usr/ports/graphics/darktable/work/darktable-1.6.7/src/iop/overexposed.c:120
120       const __m128 lower_color = _mm_load_ps(dt_iop_overexposed_colors[colorscheme][1]);
(gdb)
Comment 3 Ludger Bolmerg 2015-08-28 20:25:09 UTC
after upgrading from darktable-1.6.7 to darktable-1.6.8 error still persists
Comment 4 commit-hook freebsd_committer 2016-02-13 14:50:37 UTC
A commit references this bug:

Author: dumbbell
Date: Sat Feb 13 14:50:16 UTC 2016
New revision: 408803
URL: https://svnweb.freebsd.org/changeset/ports/408803

Log:
  graphics/darktable: Update to 2.0.1

  darktable 2.0.x officially dropped support for i386. I believe the crash
  reported in PR 202457 was specific to 32-bit because this was already
  largely untested with darktable 1.6.x, so I'm considering this issue
  "fixed".

  PR:		202457
  Reviewed by:	kwm
  Approved by:	kwm
  Differential Revision:	https://reviews.freebsd.org/D4247

Changes:
  head/graphics/darktable/Makefile
  head/graphics/darktable/distinfo
  head/graphics/darktable/files/patch-cmake_modules_FindGettext.cmake
  head/graphics/darktable/files/patch-data_CMakeLists.txt
  head/graphics/darktable/files/patch-doc_CMakeLists.txt
  head/graphics/darktable/files/patch-src_CMakeLists.txt
  head/graphics/darktable/files/patch-src_common_darktable.c
  head/graphics/darktable/files/patch-src_develop_masks_path.c
  head/graphics/darktable/pkg-plist
Comment 5 Jean-Sébastien Pédron freebsd_committer 2016-02-13 14:52:50 UTC
Hi!

I believe the crash was specific to i386. This platform was already mostly untested with darktable 1.6.x. Now with darktable 2.0.x, support for i386 was completely dropped. The update I just committed to the port limits the build of darktable to amd64.