Bug 202497 - graphics/nomacs: Fails to build (Cmake failed to find OpenCVCore)
Summary: graphics/nomacs: Fails to build (Cmake failed to find OpenCVCore)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2015-08-19 20:56 UTC by serpent7776
Modified: 2016-08-21 19:54 UTC (History)
5 users (show)

See Also:
koobs: maintainer-feedback-


Attachments
poudriere build log (6.64 KB, application/gzip)
2015-08-19 20:56 UTC, serpent7776
no flags Details
poudriere build log (36.19 KB, text/plain)
2015-12-03 00:06 UTC, serpent7776
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description serpent7776 2015-08-19 20:56:17 UTC
Created attachment 160115 [details]
poudriere build log

I cannot compile graphics/nomacs
Both graphics/opencv and graphics/opencv-core compiled and installed successfully
Comment 1 Bartek Rutkowski freebsd_committer 2015-12-01 12:28:52 UTC
Is this still an issue? I've built it on 9.3 and 10.2 amd64/i386 without any issues, could you please update the PR with the build results on freshly built 10.2-RELEASE system?
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-02 08:15:18 UTC
Maintainer feedback timeout.

cc OpenCV MAINTAINER
Comment 3 serpent7776 2015-12-03 00:06:20 UTC
Created attachment 163787 [details]
poudriere build log
Comment 4 serpent7776 2015-12-03 00:07:47 UTC
It still fails for me. I uploaded poudriere build log in case it may help.
Comment 5 Randy Westlund 2015-12-12 10:27:50 UTC
I can build nomacs-2.2.0_3 on 10.2 amd64 in a fresh jail, both with RAW support (the default) and without it (matching your options).  Maybe this is specific to poudriere?
Comment 6 John Marino freebsd_committer 2016-08-19 02:41:30 UTC
I can reproduce this with Synth so it's not specific to poudriere.  In fact, it pretty much confirms that nomacs must be missing a dependency specification.
Comment 7 John Marino freebsd_committer 2016-08-19 02:44:37 UTC
however, strangely, it builds on DragonFly with poudriere just fine.  The synth test was on FreeBSD 10.3.  It's a curious failure but I think there's something to this report.
Comment 8 John Marino freebsd_committer 2016-08-19 02:50:35 UTC
FYI, the fail (synth/freebsd) was with RAW option off and the pass (poudriere/dragonfly) was with default options (RAW is on)
Comment 9 John Marino freebsd_committer 2016-08-19 02:57:16 UTC
and synth/freebsd can build nomacs when RAW option is on (the option defaults).

So it appears that the problem is indeed centered around the RAW option.
Comment 10 commit-hook freebsd_committer 2016-08-19 03:06:24 UTC
A commit references this bug:

Author: marino
Date: Fri Aug 19 03:06:18 UTC 2016
New revision: 420443
URL: https://svnweb.freebsd.org/changeset/ports/420443

Log:
  graphics/nomacs: Fix build when RAW option turned off

  The opencv-core dependency is not limited to the RAW option.  The build
  fails in a clean jail if the RAW option is turned off due to the missing
  opencv dependency.  Change it to an unconditional LIB_DEPENDS to fix
  the build in the RAW-off configuration.

  PR:		202497
  Reported by:	serpent7776 (gmail)
  Approved by:	maintainer timeout / just-fix-it

Changes:
  head/graphics/nomacs/Makefile
Comment 11 serpent7776 2016-08-21 19:54:54 UTC
Just want to confirm it's fixed. Thanks for fixing it.