Bug 202863 - sysutils/apcupsd faulty pid handling
Summary: sysutils/apcupsd faulty pid handling
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Danilo G. Baio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-03 01:36 UTC by aepalea
Modified: 2017-06-19 23:15 UTC (History)
2 users (show)

See Also:
takefu: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aepalea 2015-09-03 01:36:11 UTC
I was trying to hack multiple UPS support by duplicating /usr/local/etc/rc.d/apcupsd under several distinct names and I got into a world of hurt with the pid file, which I traced down the pidfile variable not being passed to the apcupsd executable. 

I was able to fix this omission by adding one line, as below: 

pidfile="/var/run/apcupsd_Fred.pid"  # MODIFIED PID FILE NAME
required_files="/usr/local/etc/apcupsd/apcupsd.conf"
command_args="-P $pidfile"   # PROPOSED ADDITIONAL LINE
command="/usr/local/sbin/apcupsd"

After adding this line, pid file sanity returned to my particular hackish endeavour. 

This might be the totally wrong solution to my problem, but nevertheless the PID handling should work as advertised.
Comment 1 Rene Ladan freebsd_committer 2017-02-27 20:51:56 UTC
Maintainer reset.
Comment 2 takefu 2017-06-15 06:59:20 UTC
It can be solved with PR #180336
Comment 3 Danilo G. Baio freebsd_committer 2017-06-19 23:15:02 UTC
should be solved in ports r443914