Bug 203016 - sysutils/lxterminal: Update to 0.2.0
Summary: sysutils/lxterminal: Update to 0.2.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Martin Wilke
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2015-09-10 14:00 UTC by Walter Schwarzenfeld
Modified: 2015-12-15 14:45 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (horia)


Attachments
svn-diff lxterminal (21.43 KB, patch)
2015-09-10 14:00 UTC, Walter Schwarzenfeld
no flags Details | Diff
patch-settings_c (356 bytes, patch)
2015-09-10 14:51 UTC, Walter Schwarzenfeld
no flags Details | Diff
patch-Makefile (349 bytes, patch)
2015-09-30 09:26 UTC, Walter Schwarzenfeld
no flags Details | Diff
patch-distinfo (357 bytes, patch)
2015-09-30 09:26 UTC, Walter Schwarzenfeld
no flags Details | Diff
patch-pkg-plist (2.93 KB, patch)
2015-09-30 09:27 UTC, Walter Schwarzenfeld
no flags Details | Diff
lxterminal-diff (1.43 KB, patch)
2015-09-30 11:11 UTC, Walter Schwarzenfeld
no flags Details | Diff
lxterminal.diff (4.73 KB, patch)
2015-09-30 11:23 UTC, Walter Schwarzenfeld
no flags Details | Diff
lxterminal.diff (4.07 KB, patch)
2015-09-30 13:00 UTC, Walter Schwarzenfeld
no flags Details | Diff
lxterminal.diff (6.71 KB, patch)
2015-10-18 01:04 UTC, Walter Schwarzenfeld
no flags Details | Diff
lxterminal.diff (13.60 KB, patch)
2015-10-18 01:40 UTC, Walter Schwarzenfeld
no flags Details | Diff
lxterminal.diff (6.89 KB, patch)
2015-10-18 01:41 UTC, Walter Schwarzenfeld
koobs: maintainer-approval? (horia)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld 2015-09-10 14:00:47 UTC
Created attachment 160896 [details]
svn-diff lxterminal

Added USE_GCC=4.8+ to the Makefile. Don't compile with clang.
Comment 1 Walter Schwarzenfeld 2015-09-10 14:50:33 UTC
Add patch to solve clang error.
Comment 2 Walter Schwarzenfeld 2015-09-10 14:51:14 UTC
Created attachment 160897 [details]
patch-settings_c
Comment 3 Walter Schwarzenfeld 2015-09-11 14:47:41 UTC
Comment on attachment 160897 [details]
patch-settings_c

>--- src/setting.c.orig	2015-09-10 14:46:36 UTC
>+++ src/setting.c
>@@ -162,7 +162,7 @@ void save_setting()
> /* Deep copy settings. */
> Setting * copy_setting(Setting * setting)
> {
>-    g_return_if_fail (setting != NULL);
>+    g_return_val_if_fail (setting != NULL, FALSE);
> 
>     /* Allocate structure. */
>     Setting * new_setting = g_slice_new0(Setting);
Comment 4 Walter Schwarzenfeld 2015-09-30 09:26:18 UTC
Created attachment 161561 [details]
patch-Makefile
Comment 5 Walter Schwarzenfeld 2015-09-30 09:26:44 UTC
Created attachment 161562 [details]
patch-distinfo
Comment 6 Walter Schwarzenfeld 2015-09-30 09:27:19 UTC
Created attachment 161563 [details]
patch-pkg-plist
Comment 7 Torsten Zühlsdorff 2015-09-30 09:48:09 UTC
Hello Walter,

thanks for your work! As it seems, you provide a patch for every file. This is very complicated to work with.

It seems you invoke a command like:
svn diff Makefile > patch-Makefile

Subversion is able to diff multiple files. You can just call:
svn diff >  lxterminal.diff 

This will diff all changed files in the active directory and wrote the changes into "lxterminal.diff".

This will save much time for the committers and makes live also for you easier.
Comment 8 Walter Schwarzenfeld 2015-09-30 11:11:40 UTC
Created attachment 161566 [details]
lxterminal-diff
Comment 9 Walter Schwarzenfeld 2015-09-30 11:13:15 UTC
lxterminal.diff does not include a worthy difference of pkg-plist. Don't know how get svn diff to work, had any troubles with it (Had yesterday a discussion in an other PR).
Comment 10 Walter Schwarzenfeld 2015-09-30 11:23:58 UTC
Created attachment 161567 [details]
lxterminal.diff
Comment 11 Walter Schwarzenfeld 2015-09-30 11:24:29 UTC
Seems I got it. I hope it is now the right diff file.
Comment 12 Walter Schwarzenfeld 2015-09-30 11:27:32 UTC
> and makes live also for you easier.
No... it makes it harder. Cause svn diff never delivers right diff. I had to edit it.
Comment 13 Walter Schwarzenfeld 2015-09-30 11:28:58 UTC
In this case svn diff has no output. I had to do it with  svn diff --patch-compatible --old . --new ../ |sudo tee -a lxterminal.diff and edit it.
Comment 14 Torsten Zühlsdorff 2015-09-30 11:35:48 UTC
(In reply to Walter Schwarzenfeld from comment #12)

> No... it makes it harder. Cause svn diff never delivers right diff. 
> I had to edit it.

What makes you believe the diff is not correct? The normal "svn diff" create a fully compatible diff, which is used. This is done all day.

I believe there is a problem in your workflow or in configuration.

If you need help, just contact me. I will explain it to you.

Greetings,
Torsten
Comment 15 Walter Schwarzenfeld 2015-09-30 13:00:00 UTC
Created attachment 161568 [details]
lxterminal.diff
Comment 16 Walter Schwarzenfeld 2015-09-30 13:00:44 UTC
This should now the right file. With help from Thorsten very thanks to you.
Comment 17 Walter Schwarzenfeld 2015-10-18 01:04:04 UTC
Created attachment 162182 [details]
lxterminal.diff
Comment 18 Walter Schwarzenfeld 2015-10-18 01:40:19 UTC
Created attachment 162183 [details]
lxterminal.diff
Comment 19 Walter Schwarzenfeld 2015-10-18 01:41:27 UTC
Created attachment 162184 [details]
lxterminal.diff
Comment 20 Walter Schwarzenfeld 2015-10-24 20:52:07 UTC
Is any still wrong with it or ?
Comment 21 Kubilay Kocak freebsd_committer freebsd_triage 2015-10-25 02:51:38 UTC
@Walter as the issue is currently classified:

 * Confirmation of QA (needs-qa)
 * Pending maintainer-approval
Comment 22 Martin Wilke freebsd_committer 2015-12-05 09:39:06 UTC
Take.
Comment 23 Torsten Zühlsdorff 2015-12-14 16:12:11 UTC
(In reply to Kubilay Kocak from comment #21)

> * Pending maintainer-approval

In this point we have reached the maintainer-timeout some time ago. Implicit approval?
Comment 24 Martin Wilke freebsd_committer 2015-12-14 16:24:04 UTC
Hi,

Yes I will look in to it latest tomorrow.


-Martin
Comment 25 commit-hook freebsd_committer 2015-12-15 14:45:41 UTC
A commit references this bug:

Author: miwi
Date: Tue Dec 15 14:44:38 UTC 2015
New revision: 403780
URL: https://svnweb.freebsd.org/changeset/ports/403780

Log:
  - Update to 0.2.0
  - Switch to options helper

  PR:		203016
  Submitted by:	Walter Schwarzenfeld
  Approved by:	mat (mentor), mantainer timeout
  Differential Revision:	D4581

Changes:
  head/sysutils/lxterminal/Makefile
  head/sysutils/lxterminal/distinfo
  head/sysutils/lxterminal/pkg-plist