Bug 203258 - [NEW PORT] print/epson-inkjet-printer-escpr: Epson Inkjet Printer Driver (ESC/P-R)
Summary: [NEW PORT] print/epson-inkjet-printer-escpr: Epson Inkjet Printer Driver (ESC...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Sato
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-22 09:41 UTC by Tatsuki Makino
Modified: 2015-09-23 20:38 UTC (History)
1 user (show)

See Also:


Attachments
print/epson-inkjet-printer-escpr (40.48 KB, text/plain)
2015-09-22 09:41 UTC, Tatsuki Makino
no flags Details
test log (91.19 KB, text/plain)
2015-09-22 09:42 UTC, Tatsuki Makino
no flags Details
test log (91.09 KB, text/plain)
2015-09-22 09:43 UTC, Tatsuki Makino
no flags Details
patch for LEGAL (788 bytes, patch)
2015-09-22 11:08 UTC, Tatsuki Makino
no flags Details | Diff
Revised port (4.79 KB, application/octet-stream)
2015-09-22 13:35 UTC, Hiroki Sato
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tatsuki Makino 2015-09-22 09:41:47 UTC
Created attachment 161263 [details]
print/epson-inkjet-printer-escpr

This software is a filter program used with Common UNIX Printing System (CUPS). This can supply the high quality print with Seiko Epson Color Ink Jet Printers.
This product supports only EPSON ESC/P-R printers.
Comment 1 Tatsuki Makino 2015-09-22 09:42:46 UTC
Created attachment 161264 [details]
test log
Comment 2 Tatsuki Makino 2015-09-22 09:43:16 UTC
Created attachment 161265 [details]
test log
Comment 3 Tatsuki Makino 2015-09-22 11:08:52 UTC
Created attachment 161270 [details]
patch for LEGAL
Comment 4 Hiroki Sato freebsd_committer 2015-09-22 13:35:19 UTC
Created attachment 161272 [details]
Revised port

Thank you for your submission.  I reviewed your port skeleton and created a revised one.  The following was fixed or modified:

1. Drop GPLv3 from LICENSE.  The license terms in the distfile just say GPLv2 or later, so choosing GPLv2 is enough.

2. RESTRICTED is not required since Epson's EULA is not applicable because GPL disallows any further restriction on redistribution of the distfile.  The distfile has been copied from the original site to FreeBSD project's public FTP server and MASTER_SITES points it now.

3. Do not use USE_GCC whenever possible.  Necessary patches to fix build with Clang (and GCC) are added.

4. Fix configure.ac instead of using CPPFLAGS, LDFLAGS, and CONFIGURE_ARGS. Using result of cups-config is the most reliable way.
 
Please review this attached version and let me know if there is regression or something you are concerned about.  I will commit it after your review.
Comment 5 Tatsuki Makino 2015-09-23 02:04:46 UTC
Thank you for reviewing and creating a revised port skeleton. The revised one can be used immediately.

I added GPLv3 and RESTRICTED because we must press the agree button before downloading and GPLv3 is referred from Epson's Software License Agreement. I think the distfile is not restricted when it is redistributed from another site, too. So I want to rent space of FreeBSD project's public FTP server.

And, thank you for create patches for source files. But, I am concerned about cups-config.
I expect that when cups-client and this ports have different PREFIX, this port's pkg-plist doesn't work correctly. Perhaps, all ports that use pkg-config, cups-config, or *-config have this issue.
Comment 6 commit-hook freebsd_committer 2015-09-23 16:32:42 UTC
A commit references this bug:

Author: hrs
Date: Wed Sep 23 16:31:42 UTC 2015
New revision: 397623
URL: https://svnweb.freebsd.org/changeset/ports/397623

Log:
  Add print/epson-inkjet-printer-escpr, CUPS driver for EPSON inkjet
  printers with ESC/P-R control language under GPL.  The port name is
  the same one as Linux's while it is a bit lengthy.

  Submitted by:	tatsuki_makino@hotmail.com
  PR:		203258

Changes:
  head/print/Makefile
  head/print/epson-inkjet-printer-escpr/
  head/print/epson-inkjet-printer-escpr/Makefile
  head/print/epson-inkjet-printer-escpr/distinfo
  head/print/epson-inkjet-printer-escpr/files/
  head/print/epson-inkjet-printer-escpr/files/patch-configure.ac
  head/print/epson-inkjet-printer-escpr/files/patch-lib-Makefile.am
  head/print/epson-inkjet-printer-escpr/files/patch-lib-epson-escpr-api-private.h
  head/print/epson-inkjet-printer-escpr/files/patch-src-Makefile.am
  head/print/epson-inkjet-printer-escpr/files/patch-src-filter.c
  head/print/epson-inkjet-printer-escpr/files/patch-src-mem.c
  head/print/epson-inkjet-printer-escpr/pkg-descr
  head/print/epson-inkjet-printer-escpr/pkg-plist
Comment 7 Hiroki Sato freebsd_committer 2015-09-23 20:38:36 UTC
(In reply to Tatsuki Makino from comment #5)

Thanks for your feedback.  Committed it for now.

For PREFIX stuff, it is true that pkg-plist becomes broken when cups-config --datadir returns a different PREFIX.  However, the same PREFIX is substantially required to install the filter program to the expected location.

Different PREFIXes which FreeBSD Ports Collection (currently) supports is just for library location, not other binaries or data files.  Although it should eventually be improved in some way, I think relying on cups-config is okay at this moment.  I will revisit it if it should be modified in the future.