Bug 203424 - databases/libzdb & sqlite3 configure failure
Summary: databases/libzdb & sqlite3 configure failure
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Only Me
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-28 20:00 UTC by pyo
Modified: 2016-03-03 10:02 UTC (History)
2 users (show)

See Also:


Attachments
see lines 122-124 (8.33 KB, text/plain)
2016-02-29 00:01 UTC, pyo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description pyo 2015-09-28 20:00:52 UTC
Using make on configure fails to find sqlite3_open and port compiling without sqlite support.
But running ./configure from work directory finds sqlite3_open and enables sqlite support on compiling.
Comment 1 pyo 2015-09-28 22:02:06 UTC
Previous version of port (3.0_1 22 Nov 2014 20:40:09) works fine.
Comment 2 Raphael Kubo da Costa freebsd_committer 2016-02-28 23:00:23 UTC
Is this still a problem with 3.1?
Comment 3 pyo 2016-02-28 23:22:19 UTC
(In reply to Raphael Kubo da Costa from comment #2)

The problem is with 3.1.

Previous version builds fine.
Comment 4 Raphael Kubo da Costa freebsd_committer 2016-02-28 23:36:11 UTC
Is that with the SQLITE option enabled or disabled? I just tried both here with Poudriere and an 11amd64 jail and they worked fine.

Can you attach a build log showing the problem to this bug report?
Comment 5 pyo 2016-02-29 00:01:34 UTC
Created attachment 167532 [details]
see lines 122-124
Comment 6 Raphael Kubo da Costa freebsd_committer 2016-02-29 00:21:39 UTC
Thanks, I can see the problem now.
Comment 7 commit-hook freebsd_committer 2016-02-29 00:31:27 UTC
A commit references this bug:

Author: rakuco
Date: Mon Feb 29 00:30:41 UTC 2016
New revision: 409792
URL: https://svnweb.freebsd.org/changeset/ports/409792

Log:
  Fix the port's configure script to properly detect SQLite3.

  This has been broken since r397227 ("Upgrade to 3.1"): the port's build system
  passes -ldl when trying to detect SQLite3. Since this will always fail on
  FreeBSD, SQLite3 support will always be disabled as well.

  PR:		203424
  MFH:		2016Q1

Changes:
  head/databases/libzdb/Makefile
  head/databases/libzdb/files/
  head/databases/libzdb/files/patch-configure
Comment 8 Raphael Kubo da Costa freebsd_committer 2016-02-29 00:31:54 UTC
Fixed, thanks for the report.
Comment 9 pyo 2016-02-29 00:34:35 UTC
(In reply to commit-hook from comment #7)

Thank you.
Comment 10 commit-hook freebsd_committer 2016-03-02 16:23:12 UTC
A commit references this bug:

Author: rakuco
Date: Wed Mar  2 16:22:10 UTC 2016
New revision: 409952
URL: https://svnweb.freebsd.org/changeset/ports/409952

Log:
  MFH: r409792

  Fix the port's configure script to properly detect SQLite3.

  This has been broken since r397227 ("Upgrade to 3.1"): the port's build system
  passes -ldl when trying to detect SQLite3. Since this will always fail on
  FreeBSD, SQLite3 support will always be disabled as well.

  PR:		203424

  Approved by:	ports-secteam (junovitch)

Changes:
_U  branches/2016Q1/
  branches/2016Q1/databases/libzdb/Makefile
  branches/2016Q1/databases/libzdb/files/
Comment 11 commit-hook freebsd_committer 2016-03-03 10:02:07 UTC
A commit references this bug:

Author: rakuco
Date: Thu Mar  3 10:01:10 UTC 2016
New revision: 410019
URL: https://svnweb.freebsd.org/changeset/ports/410019

Log:
  Partially revert r409952.

  Switch back to USE_SQLITE=3 instead of USES=sqlite because the 2016Q1 branch
  does not support the latter.

  PR:		203424
  Approved by:	portmgr (antoine)

Changes:
  branches/2016Q1/databases/libzdb/Makefile