Bug 203571 - Can't build multimedia/ffmpeg & multimedia/ffmpeg0 ; missing doc files
Summary: Can't build multimedia/ffmpeg & multimedia/ffmpeg0 ; missing doc files
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-06 02:12 UTC by fossette
Modified: 2015-10-10 18:14 UTC (History)
3 users (show)

See Also:


Attachments
portmaster -L (31.72 KB, text/plain)
2015-10-06 02:12 UTC, fossette
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description fossette 2015-10-06 02:12:24 UTC
Created attachment 161747 [details]
portmaster -L

I was trying to upgrade my ports (because of firefox issues), and got stuck at ffmpeg, which in turn prevents a bunch of other ports to be upgraded.


***

# uname -a
FreeBSD newb 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 21:02:49 UTC 2014     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64


***

# make
...
gmake[2]: Leaving directory '/usr/ports/multimedia/ffmpeg/work/ffmpeg-2.8'
install  -m 444 /usr/ports/multimedia/ffmpeg/work/ffmpeg-2.8/doc/ffmpeg*.1 /usr/ports/multimedia/ffmpeg/work/stage/usr/local/man/man1/
install: /usr/ports/multimedia/ffmpeg/work/ffmpeg-2.8/doc/ffmpeg*.1: No such file or directory
*** Error code 71


***

# make
...
install  -m 0644 /usr/ports/multimedia/ffmpeg0/work/ffmpeg-0.7.17/doc/*.html /usr/ports/multimedia/ffmpeg0/work/stage/usr/local/share/doc/ffmpeg0
install: /usr/ports/multimedia/ffmpeg0/work/ffmpeg-0.7.17/doc/*.html: No such file or directory
*** Error code 71
Comment 1 fossette 2015-10-09 05:53:39 UTC
After reading about similar problems with other ports on the FreeBSD Forums, I checked my system for the same pattern, and got the problem solved.  So, I'll switch this bug report state to closed, but I have no idea how it came about, nor how to reproduce it.

In a similar problem post, one user mentioned having encountered a similar problem when perl wasn't up to date.  But as listed in my portmaster list, my version of perl is right.  Another user asked for some installation log file (sorry, I don't recall the name).  The one I found had a line saying the /usr/local/bin/perl was missing.  Wtf?

To fix this mess, I ran (in the /usr/ports/lang/perl5.20/ directory):
# portsnap fetch update    (just to be sure)
# make deinstall
# make install clean

I was then able to built the other ports successfully, multimedia/ffmpeg etc...
Comment 2 Chris Hutchinson 2015-10-10 18:14:51 UTC
(In reply to fossette from comment #1)
> 
> In a similar problem post, one user mentioned having encountered a similar
> problem when perl wasn't up to date.  But as listed in my portmaster list,
> my version of perl is right.  Another user asked for some installation log
> file (sorry, I don't recall the name).  The one I found had a line saying
> the /usr/local/bin/perl was missing.  Wtf?
> 
> To fix this mess, I ran (in the /usr/ports/lang/perl5.20/ directory):
> # portsnap fetch update    (just to be sure)
> # make deinstall
> # make install clean
Yes. That's because the current state of Perl [on FreeBSD] is a
bit of a disaster. I believe there is some mention of it in UPDATING.
But it is not yet completely cleaned up/cured.