Bug 203588 - [ufs] fsck_ufs segfaults during journals after powerloss
Summary: [ufs] fsck_ufs segfaults during journals after powerloss
Status: Closed Not Enough Information
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.2-RELEASE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-fs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-06 13:32 UTC by Julien Cigar
Modified: 2016-08-24 20:43 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Cigar 2015-10-06 13:32:55 UTC
Hello,

I just had a powerloss with y desktop machine (which is not on an UPS). The machine is running:

FreeBSD frodon 10.2-RELEASE-p2 FreeBSD 10.2-RELEASE-p2 #2 r287854: Thu Sep 17 11:37:46 CEST 2015     root@frodon:/usr/obj/usr/src/sys/CUSTOM  amd64

After reboot SU+J was unable to recover the journal (segfaulting). A full fsck hopefully worked ..

I took a couple of screenshots which are available from here: http://home.bebif.be/~jcigar/ufs/
I can provide more information if needed ..
Comment 1 amvandemore 2015-11-17 19:57:45 UTC
Yes this is a bug.  Unfortunately, this type of PR is almost useless since there is no actionable information included.  I don't know any devs who love wild goose chases.

If it happens again, better ways to handle this are:

1.  Snapshot the underlying block device so there is always access to the problematic state.
2.  Run "fsck_ffs -d" and "fsck_ffs -f -d" and ensure the output is saved eg script(1).

See bug #187221 for an example of an actionable PR.

Also what does this "A full fsck hopefully worked .." mean?  Did a full fsck work?  If yes then there is no need to mention it and if no it needs to be in the PR.
Comment 2 Kirk McKusick freebsd_committer 2016-08-24 20:43:17 UTC
As noted this report does not have enough information to reproduce the problem.

Several bug fixes have been made to fsck that may have been relevant to this report.