Bug 203651 - [MAINTAINER] www/qupzilla-qt{4,5}: update to 1.8.7
Summary: [MAINTAINER] www/qupzilla-qt{4,5}: update to 1.8.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Mathieu Arnold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-09 05:20 UTC by Matthew Rezny
Modified: 2015-10-15 14:15 UTC (History)
1 user (show)

See Also:


Attachments
update www/qupzilla to 1.8.7 (3.09 KB, patch)
2015-10-09 05:20 UTC, Matthew Rezny
rezny: maintainer-approval+
Details | Diff
update www/qupzila to 1.8.7 (4.33 KB, patch)
2015-10-15 04:40 UTC, Matthew Rezny
rezny: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Rezny freebsd_committer 2015-10-09 05:20:19 UTC
Created attachment 161838 [details]
update www/qupzilla to 1.8.7

Update QupZilla ports to 1.8.7 which brings a number of bugfixes for the Qt5 build. KWallet support on for KDE5 is available as an option now that it is clear how KF5 ports will work (tested with area51). Also, change the conflict between variants to just be an install conflict to ease test builds.
Comment 1 Mathieu Arnold freebsd_committer 2015-10-14 13:53:25 UTC
-qt5 fails with:

===>  Configuring for qupzilla-qt5-1.8.7
Reading /wrkdirs/usr/ports/www/qupzilla-qt5/work/QupZilla-1.8.7/src/lib/lib.pro
Project MESSAGE: ===========================================
Project MESSAGE: Using following defines:
Project MESSAGE: QUPZILLA_SHAREDLIBRARY QUPZILLA_VERSION=\"1.8.7\" QT_NO_URL_CAST_FROM_STRING QT_USE_QSTRINGBUILDER USE_QTWEBKIT_2_2 USE_QTWEBKIT_2_3 USE_LIBPATH=\"/usr/local//lib\" USE_DATADIR=\"/usr/local//share/qupzilla\" QZ_WS_X11 QT_STATICPLUGIN USE_HUNSPELL
Project ERROR: Unknown module(s) in QT: x11extras
*** Error code 3
Comment 2 Matthew Rezny freebsd_committer 2015-10-15 04:40:01 UTC
Created attachment 162057 [details]
update www/qupzila to 1.8.7

Nobody else testing the -qt5 variant has reported this problem. There's not much context for the failure report so I'll assume it's with poudriere and x11extras wasn't available in the build jail because it's not listed in the port but presumably is required. That appears to be a new thing for Qt5 so only affects this newer port variant. I refreshed the patch with that addition.
Comment 3 commit-hook freebsd_committer 2015-10-15 14:15:10 UTC
A commit references this bug:

Author: mat
Date: Thu Oct 15 14:14:07 UTC 2015
New revision: 399339
URL: https://svnweb.freebsd.org/changeset/ports/399339

Log:
  Update to 1.8.7.

  PR:		203651
  Submitted by:	maintainer
  Sponsored by:	Absolight

Changes:
  head/www/qupzilla-qt4/Makefile
  head/www/qupzilla-qt4/distinfo
  head/www/qupzilla-qt4/pkg-plist
  head/www/qupzilla-qt5/Makefile
  head/www/qupzilla-qt5/distinfo
  head/www/qupzilla-qt5/pkg-plist