Bug 203903 - [NEW PORT] devel/maven: Java project management tool (3.3.x)
Summary: [NEW PORT] devel/maven: Java project management tool (3.3.x)
Status: Closed DUPLICATE of bug 188110
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: feature, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2015-10-20 22:37 UTC by Mark Dixon
Modified: 2015-10-24 18:46 UTC (History)
2 users (show)

See Also:


Attachments
Shar for maven33 (7.15 KB, text/plain)
2015-10-20 22:37 UTC, Mark Dixon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Dixon 2015-10-20 22:37:40 UTC
Created attachment 162261 [details]
Shar for maven33

Create a port for Maven 3.3, based (heavily) on the Maven 3.1 port.
Comment 1 Kurt Jaeger freebsd_committer 2015-10-21 12:09:58 UTC
See also
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=188110
Comment 2 Kurt Jaeger freebsd_committer 2015-10-21 12:13:37 UTC
Somehow, we have plenty of suggested ports, but not the courage to say: That's the right way to do it.
Comment 3 Kurt Jaeger freebsd_committer 2015-10-21 19:14:42 UTC
This version has

INSTANCE_FILE= 030101-${PORTNAME}-${PORTVERSION}

while the latest version in

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=188110

has

030303-${PORTNAME}-${PORTVERSION}

Can somebody explain the difference to me ?

And: There are differences in the startup-scripts provided.

Can we find a common ground ?
Comment 4 Mark Dixon 2015-10-22 07:20:16 UTC
I think we move this discussion to the other bug and focus on getting a single devel/maven
Comment 5 Mark Dixon 2015-10-22 08:54:59 UTC
To reply to your comment, the INSTANCE file looks like something I missed when copying the maven31 port. I'd have to look at the other startup script.
Comment 6 Kurt Jaeger freebsd_committer 2015-10-24 18:46:53 UTC
As suggested by submitter, we move the discussion to 188110

*** This bug has been marked as a duplicate of bug 188110 ***