Bug 204221 - audio/speex: /usr/local/lib/libspeexdsp.la' is not a valid libtool archive
Summary: audio/speex: /usr/local/lib/libspeexdsp.la' is not a valid libtool archive
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-multimedia mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-02 11:53 UTC by O. Hartmann
Modified: 2015-11-02 16:18 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (multimedia)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2015-11-02 11:53:58 UTC
Updating/recompiling and/or installing of port audio/speex fails with this error:


[...]
--- speexenc ---
  CCLD     speexenc
libtool: link: `/usr/local/lib/libspeexdsp.la' is not a valid libtool archive
*** [speexenc] Error code 1
Comment 1 Tijl Coosemans freebsd_committer 2015-11-02 13:00:10 UTC
Try UPDATING entry 20140909 regarding build problems with .la files.
Comment 2 O. Hartmann 2015-11-02 16:02:29 UTC
Thanks for the hint.

The problem was triggered by two remnant .la files, dated to January, 2015. Since portmaster does sometimes not a proper job, I guess those files have accidentally left over. I checked for for other files with the find command given as you referred to and I found that only port graphics/graphviz:

 /usr/local/lib/graphviz/libgvplugin_xlib.la was installed by package graphviz-2.38.0_10

installs such a libtool archive.

Kind regards, thanks and please close the PR,

oh