Bug 204353 - can't build editors/libreoffice
Summary: can't build editors/libreoffice
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Office Team (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-07 07:11 UTC by gja822
Modified: 2018-03-01 17:18 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments
Stack from cppunittester.core (29.58 KB, text/plain)
2017-06-04 14:09 UTC, Mikhail T.
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description gja822 2015-11-07 07:11:02 UTC
On 10-stable (FreeBSD 10.2-STABLE #0 r290265M on amd64) and portupgrade()d ports I can't build editors/libreoffice with base clang nor with clang36 from ports. I thought that rebuilt all it's dependencies, but no luck. Tried with minimal options (default CUPS and CTK2) and my default (CUPS, GTK2, VERBOSE, JAVA). Can't figure out, what else need to be rebuilt (or fixed any other way). I had working libreoffice4 before this. Compilation stops with these errors:


[build CUT] cppu_qa_any
Segmentation fault (core dumped)
OK (39)

No core file identified in directory /usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/basegfx.test.core
To show backtraces for crashes during test execution,
enable core files with:

   ulimit -c unlimited


Error: a unit test failed, please do one of:

export DEBUGCPPUNIT=TRUE            # for exception catching
export CPPUNITTRACE="gdb --args"    # for interactive debugging on Linux
export VALGRIND=memcheck            # for memory checking

and retry using: make CppunitTest_basegfx

/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/solenv/gbuild/CppunitTest.mk:87: recipe for target '/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/basegfx.test' failed
gmake[3]: *** [/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/basegfx.test] Error 1
gmake[3]: *** Waiting for unfinished jobs....
Segmentation fault (core dumped)
OK (6)

No core file identified in directory /usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/comphelper_syntaxhighlight_test.test.core
To show backtraces for crashes during test execution,
enable core files with:

   ulimit -c unlimited


Error: a unit test failed, please do one of:

export DEBUGCPPUNIT=TRUE            # for exception catching
export CPPUNITTRACE="gdb --args"    # for interactive debugging on Linux
export VALGRIND=memcheck            # for memory checking

and retry using: make CppunitTest_comphelper_syntaxhighlight_test

/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/solenv/gbuild/CppunitTest.mk:87: recipe for target '/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/comphelper_syntaxhighlight_test.test' failed
gmake[3]: *** [/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/comphelper_syntaxhighlight_test.test] Error 1
Segmentation fault (core dumped)
OK (12)

No core file identified in directory /usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/comphelper_test.test.core
To show backtraces for crashes during test execution,
enable core files with:

   ulimit -c unlimited


Error: a unit test failed, please do one of:

export DEBUGCPPUNIT=TRUE            # for exception catching
export CPPUNITTRACE="gdb --args"    # for interactive debugging on Linux
export VALGRIND=memcheck            # for memory checking

and retry using: make CppunitTest_comphelper_test

/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/solenv/gbuild/CppunitTest.mk:87: recipe for target '/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/comphelper_test.test' failed
gmake[3]: *** [/usr/ports/editors/libreoffice/work/libreoffice-5.0.3.2/workdir/CppunitTest/comphelper_test.test] Error 1
Comment 1 Mikhail T. 2017-06-04 03:03:19 UTC
I have the same issue today - on FreeBSD-11.1/i386.

The builds of editors/libreoffice (5.3.3) are dying due to crashes of cppunittester-executable. Depending on the options, the crash happens in different tests.
Comment 2 Mikhail T. 2017-06-04 14:09:17 UTC
Created attachment 183202 [details]
Stack from cppunittester.core

Here is the stack from a sample cppunittester.core I'm finding in CppunitTest/sw_odfimport.test.core/ after a build failure...
Comment 3 Jung-uk Kim freebsd_committer 2017-06-07 22:59:48 UTC
I turned off all unit test by default, i.e., r442891.  It should work around your build issues.
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-01-13 23:17:01 UTC
Is this still relevant? Or is it solved? If it is solved, please close here.