Bug 204384 - math/saga: Fails to build with GCC 4.9
Summary: math/saga: Fails to build with GCC 4.9
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Gerald Pfeifer
URL:
Keywords: needs-qa
Depends on:
Blocks: 196712
  Show dependency treegraph
 
Reported: 2015-11-09 09:00 UTC by Gerald Pfeifer
Modified: 2016-01-10 11:07 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer freebsd_committer 2015-11-09 09:00:33 UTC
We are working to move the default version of GCC in ports (lang/gcc)
from GCC 4.8 to GCC 4.9.

Sadly this port is one of a few that blocks this update, cf.

http://package22.nyi.freebsd.org/data/101amd64-default-PR196712/2015-10-25_21h38m31s/logs/errors/saga-2.2.2.log
Comment 1 Rainer Hurling 2015-11-18 20:41:40 UTC
Sorry for the late answer. I tried to upgrade poudriere jails before checking ports build and that failed for some days now. 

I just built math/saga with poudriere jails 10.2 and 9.3 (both amd64) with setting 'DEFAULT_VERSIONS+= gcc=4.9' in /usr/local/etc/poudriere.d/make.conf. Log files are available, if needed.

Both builds ran fine, so with my configuration I am not able to reproduce the error in your log:

../saga_api/.libs/libsaga_api.so: undefined reference to `__cxa_throw_bad_array_new_length'
collect2: error: ld returned 1 exit status


I am not sure, if this is the needed configure for (future) gcc 4.9 default configuration.
Comment 2 Rainer Hurling 2016-01-10 07:39:23 UTC
Hmm, is there any reason _not_ to close this bug?

[I also tested math/saga with lang/gcc49 in VirtualBox on 9.3 and HEAD. As with Pourdriere, I was not able to reproduce your error, described above.]
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-10 08:03:15 UTC
Reporter is committer, assign accordingly
Comment 4 Gerald Pfeifer freebsd_committer 2016-01-10 11:07:40 UTC
Okay, then let's assume this either was a hickup around the -exp run
or that it has been addressed by some (un?)related changes in the 
meantime.

Thanks for digging into this and trying to reproduce!