Bug 204665 - emulators/virtualbox-ose: boot time hang on CURRENT
Summary: emulators/virtualbox-ose: boot time hang on CURRENT
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-18 19:56 UTC by Michael Galassi
Modified: 2019-09-06 19:48 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments
VBoxManage list hostonlyifs output (71.28 KB, text/plain)
2015-11-18 19:56 UTC, Michael Galassi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Galassi 2015-11-18 19:56:50 UTC
Created attachment 163298 [details]
VBoxManage list hostonlyifs output

The line:

LD_LIBRARY_PATH=/usr/local/lib /usr/local/bin/VBoxManage list hostonlyifs >/dev/null
in file:
/usr/local/etc/rc.d/vboxnet

Hangs on boot.  It is interruptible (stuck in a poll loop).  This seems to be a regression with 4.3.34.  The same command run after boot hangs too.

I reproduced this on a system where I built from ports as well as one where I installed using pkg.

[root@penguin ~]# pkg info | grep virtualbox
virtualbox-ose-4.3.34_1        General-purpose full virtualizer for x86 hardware
virtualbox-ose-additions-4.3.34 VirtualBox additions for FreeBSD guests
virtualbox-ose-kmod-4.3.34     VirtualBox kernel module for FreeBSD
[root@penguin ~]# kldstat | grep vbox
 8    1 0xffffffff81621000 2704a    vboxguest.ko
10    2 0xffffffff8164d000 29de     vboxnetflt.ko
12    2 0xffffffff8165c000 45d20    vboxdrv.ko
14    1 0xffffffff816a7000 3f6c     vboxnetadp.ko

I've attached the output of
truss /usr/local/bin/VBoxManage list hostonlyifs
Comment 1 mikael.urankar 2015-11-19 08:51:49 UTC
Same here, the trick found in this forum post fixes the problem:
https://forums.freebsd.org/threads/virtualbox-4-3-26-wont-start.51341/#post-287831
Comment 2 Michael Galassi 2015-11-19 20:39:44 UTC
As mikael.urankar@gmail.com pointed out, this is easily worked around with:

# mkdir -p /usr/local/etc/libmap.d
# echo "libcrypto.so.7 libcrypto.so.8" > /usr/local/etc/libmap.d/virtualbox.conf

Thank you Mikael.
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-01-12 23:38:59 UTC
Is this still relevant or could this be closed?