Bug 204677 - net/minidlna: [patch] simplified startup and fixed service stopping.
Summary: net/minidlna: [patch] simplified startup and fixed service stopping.
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Gleb Smirnoff
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-11-19 13:51 UTC by c.kworr
Modified: 2019-01-09 04:17 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (glebius)


Attachments
fixes for startup script (930 bytes, patch)
2015-11-19 13:51 UTC, c.kworr
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description c.kworr 2015-11-19 13:51:57 UTC
Created attachment 163328 [details]
fixes for startup script

This patch addresses following issues:

1. minidlnad has no support for -u flag so stop using it.
2. Instead of relaying to minidlnad switching to restricted user force RC to run minidlnad under $minidlna_user.
3. minidlnad doesn't quit for me on SIGTERM thus adding sig_stop=3. I'm using KQUEUE patch, can this be it?
Comment 1 William Grzybowski freebsd_committer 2015-11-19 16:59:24 UTC
3. SIGSTOP doesn't make sense to me. Do you know what it actually does? And yes, thats high likely because of kqueue patch.
Comment 2 c.kworr 2015-11-19 21:40:21 UTC
Yep, my bad. Already figured that out.
Comment 3 w.schwarzenfeld freebsd_triage 2018-01-12 23:43:17 UTC
I think this could closed.
Comment 4 Gleb Smirnoff freebsd_committer 2019-01-09 04:17:27 UTC
1. minidlna has -u 
3. The kqueue patch is now longer.