Bug 204845 - comms/efax: Core dumps on amd64
Summary: comms/efax: Core dumps on amd64
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Thomas Zander
URL:
Keywords: crash, easy, needs-qa, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-11-27 12:59 UTC by yama
Modified: 2015-11-29 16:59 UTC (History)
1 user (show)

See Also:
riggs: merge-quarterly+


Attachments
A patch file for solution. (661 bytes, patch)
2015-11-27 12:59 UTC, yama
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yama 2015-11-27 12:59:12 UTC
Created attachment 163581 [details]
A patch file for solution.

I install comms/efax using pkg command on FreeBSD10.1/amd64. The program stops with core dump.

How to reproduce:
* Edit a configuration file /usr/local/etc/efax.rc.
* Run a command as bellow.
    fax send FAX-NUMBER FILENAME

Reason:
A variable (va_list ap) is broken.

Solution:
Apply patch. This patch initializes the variable ap every time in a for loop.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-27 13:17:46 UTC
Comment on attachment 163581 [details]
A patch file for solution.

Port is un-maintained, implicit approval
Comment 2 commit-hook freebsd_committer 2015-11-29 16:52:16 UTC
A commit references this bug:

Author: riggs
Date: Sun Nov 29 16:52:06 UTC 2015
New revision: 402606
URL: https://svnweb.freebsd.org/changeset/ports/402606

Log:
  Fix runtime segfault due to uninitialised variable, bump PORTREVISION

  While on it:
  - Pet portlint: regenerate patches using 'make makepatch'
  - Add LICENSE

  PR:		204845
  Submitted by:	yama@jasper.co.jp
  MFH:		2015Q4 (ports-secteam fix blanket)

Changes:
  head/comms/efax/Makefile
  head/comms/efax/files/patch-Makefile
  head/comms/efax/files/patch-efaxmsg.c
  head/comms/efax/files/patch-fax
  head/comms/efax/files/patch-src_Makefile
  head/comms/efax/files/patch-src_fax
Comment 3 commit-hook freebsd_committer 2015-11-29 16:56:18 UTC
A commit references this bug:

Author: riggs
Date: Sun Nov 29 16:56:06 UTC 2015
New revision: 402607
URL: https://svnweb.freebsd.org/changeset/ports/402607

Log:
  MFH: r402606

  Fix runtime segfault due to uninitialised variable, bump PORTREVISION

  While on it:
  - Pet portlint: regenerate patches using 'make makepatch'
  - Add LICENSE

  PR:		204845
  Submitted by:	yama@jasper.co.jp
  Approved by:	ports-secteam (fix blanket)

Changes:
_U  branches/2015Q4/
  branches/2015Q4/comms/efax/Makefile
  branches/2015Q4/comms/efax/files/patch-Makefile
  branches/2015Q4/comms/efax/files/patch-efaxmsg.c
  branches/2015Q4/comms/efax/files/patch-fax
  branches/2015Q4/comms/efax/files/patch-src_Makefile
  branches/2015Q4/comms/efax/files/patch-src_fax