Bug 204942 - lang/sbcl: Update to 1.3.1
Summary: lang/sbcl: Update to 1.3.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: John Marino
URL:
Keywords: patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-12-01 18:09 UTC by Account Removed
Modified: 2015-12-02 19:18 UTC (History)
1 user (show)

See Also:


Attachments
lang/sbcl (8.96 KB, patch)
2015-12-01 18:09 UTC, Account Removed
koobs: maintainer-approval+
Details | Diff
portlint (887 bytes, text/plain)
2015-12-01 18:10 UTC, Account Removed
no flags Details
poudriere: bootstrap from 1.2.7 (864.60 KB, text/plain)
2015-12-01 18:12 UTC, Account Removed
no flags Details
lang/sbcl (7.15 KB, patch)
2015-12-02 11:08 UTC, Account Removed
koobs: maintainer-approval+
Details | Diff
portlint (814 bytes, text/plain)
2015-12-02 11:09 UTC, Account Removed
no flags Details
poudriere (882.37 KB, text/plain)
2015-12-02 11:09 UTC, Account Removed
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Account Removed 2015-12-01 18:09:34 UTC
Created attachment 163719 [details]
lang/sbcl

Made the port fetch boostrap binaries from sourceforge. This may be not the best way to convert ${ARCH} to their format:

.if ${ARCH} == amd64
BOOTARCH=       x86-64
.endif
.if ${ARCH} == i386
BOOTARCH=       x86
.endif

For some reason, ".if make(makesum)" does not work.

Has this issue
https://lists.freebsd.org/pipermail/freebsd-ports-bugs/2015-January/300055.html
been resolved? Is it safe to uncomment "THREADS" now?
Comment 1 Account Removed 2015-12-01 18:10:16 UTC
Created attachment 163720 [details]
portlint
Comment 2 Account Removed 2015-12-01 18:12:30 UTC
Created attachment 163721 [details]
poudriere: bootstrap from 1.2.7
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-02 08:23:24 UTC
Comment on attachment 163719 [details]
lang/sbcl

Port is unmaintained, implicit approval
Comment 4 John Marino freebsd_committer 2015-12-02 08:30:01 UTC
No, this patch smells wrong with regard to dragonfly.

The bootstrap version changed from 1.2.9 to 1.2.7 and the LOCAL/marino source was stripped off without explanation.

I would consider this UNAPPROVED until this is sorted out.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-02 08:32:51 UTC
(In reply to John Marino from comment #4)

Feel free to take (assign) the issue to resolution. However, maintainer-approval is implicit (thus +) in the absence of a port maintainer (unmaintained).

However, maintainer-approval + does not also mean 'patch is ready/good to commit), so feel free to:

- Obsolete attachment 163719 [details] with comment
- Set needs-patch to signify an updated patch is necessary
Comment 6 John Marino freebsd_committer 2015-12-02 08:37:56 UTC
I'm not going to obsolete a patch without first uploading a replacement patch, which I don't have.  I'm just saying that as it stands how, this patch should not be considered good-to-go yet.

1) The changes to dragonfly need to be explained (I expect this is an error)
2) The patch (or replacement patch) needs to be tested on dragonfly first, which I can do once I hear about #1.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-02 08:44:15 UTC
(In reply to John Marino from comment #6)

That's fine. I would recommend you take the issue to resolution, in case someone else does. As assignee you have additional discretion (to obsolete, or request new patch, etc)
Comment 8 Account Removed 2015-12-02 08:50:03 UTC
The reference to LOCAL/marino was stripped because of absence of 1.2.7 there, as well I thought it would be more consistent to fetch binaries directly from authors. Once LOCAL/marino has 1.2.7 binaries, that can be re-added?

The change of dragonfly from 1.2.7 is, on the contrary, caused by the absence of 1.2.9 on sourceforge: http://sourceforge.net/projects/sbcl/files/sbcl/1.2.9/. And again, it might be more consistent to have all three platrofms bootstrapped from the same version.
Comment 9 Account Removed 2015-12-02 08:51:53 UTC
In LICENSE_PERMS I had forgotten "dist-sell pkg-sell".
Comment 10 John Marino freebsd_committer 2015-12-02 08:57:21 UTC
no, it's clear that the bootstrap versions do not have to match the upcoming target, only that they build it.

Example: FreeBSD bootstrap is currently 1.1.0 and builds 1.2.9.

Why would I put a lower 1.2.7 in LOCAL/marino when 1.2.9 is already there? this make no sense.

Also, where does "sbcl-1.2.7-x86-64-dragonfly-binary.tar.bz2" come from?  Who built it?  Is it on SF?


My recommendation is to keep dragonfly how it was, using the same bootstrap it already was.
Comment 11 Account Removed 2015-12-02 09:40:09 UTC
The binaries are from here: http://sourceforge.net/projects/sbcl/files/sbcl/1.2.7/
I am not sure who built them. If you insist, I will revert to LOCAL/marino.

Recommendation accepted, will change dragonfly bootstrap back.
Comment 12 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-02 10:02:18 UTC
Thank you Michael, could you update your poudriere log after those changes too please :)
Comment 13 John Marino freebsd_committer 2015-12-02 10:06:12 UTC
(In reply to Michael Danilov from comment #11)

In the future, if the bootstraps are newer than 1.2.9, we can probably safely switch to using the provided SF bootstraps.  Until then, I prefer that you use the newer-version bootstrap that I built.

DragonFly support on SBCL is pretty recent and I don't know if it's properly supported in 1.2.7.
Comment 14 Account Removed 2015-12-02 11:08:35 UTC
Created attachment 163745 [details]
lang/sbcl

reverted bootstraps to LOCAL/marino
Comment 15 Account Removed 2015-12-02 11:09:05 UTC
Created attachment 163746 [details]
portlint
Comment 16 Account Removed 2015-12-02 11:09:46 UTC
Created attachment 163747 [details]
poudriere
Comment 17 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-02 11:15:00 UTC
Comment on attachment 163745 [details]
lang/sbcl

Port is unmaintained, implicit approval
Comment 18 Kubilay Kocak freebsd_committer freebsd_triage 2015-12-02 11:15:23 UTC
Thank you Michael
Comment 19 John Marino freebsd_committer 2015-12-02 11:23:03 UTC
some of these portlint warnings might be valid.
Comment 20 John Marino freebsd_committer 2015-12-02 11:25:23 UTC
okay, interesting, you keep the original FreeBSD bootstraps as well.  If they still work, why not?  It definitely makes the upgrade patch simpler.
Comment 21 Account Removed 2015-12-02 11:32:40 UTC
You were not very clear about FreeBSD bootstraps. Should I only use LOCAL/marino for Dragonfly?
Comment 22 John Marino freebsd_committer 2015-12-02 11:33:56 UTC
that's what I had in mind, but I prefer the patch as it currently is.

As long as the original bootstraps work, let's keep using them.
Comment 23 John Marino freebsd_committer 2015-12-02 19:07:43 UTC
okay, when portlint is run with the patch in place, all the warnings left are acceptable.  (no changes necessary)
Comment 24 commit-hook freebsd_committer 2015-12-02 19:17:15 UTC
A commit references this bug:

Author: marino
Date: Wed Dec  2 19:16:50 UTC 2015
New revision: 402845
URL: https://svnweb.freebsd.org/changeset/ports/402845

Log:
  lang/sbcl: Upgrade version 1.2.9 => 1.3.1

  PR:		204942
  Submitted by:	Michael Danilov

Changes:
  head/lang/sbcl/Makefile
  head/lang/sbcl/distinfo
  head/lang/sbcl/files/
  head/lang/sbcl/pkg-plist
Comment 25 John Marino freebsd_committer 2015-12-02 19:18:26 UTC
it built great on DragonFly, thanks!